GNS3 Recommended hardware Specs and Minimum basic Requirements

GNS3 Recommended hardware Specs and basic Requirements

This article is about the hardware specification of GNS3, we will discuss the minimum hardware requirement and recommended hardware requirement for different scenarios. GNS3 the most popular network simulator use for simulating different virtual and real devices for creating the network labs. GNS3 base on Dynamips emulation software to simulating real IOS of Cisco. Since it is using the real router IOS of routers, therefore, its hardware requirement higher as compare to other network simulators. Also, GNS3's hardware requirements depend upon on the number of virtual devices you use in your Network Lab, therefore we discuss the different network scenarios and their hardware requirements according to different network engineers.


Minimum Hardware Requirements For Gns3:

As it is discussed earlier that there is no fixed minimum hardware requirement for GNS3 it depends on the number of virtual devices you use in your network topology. For minimum requirements suppose you want to create a network topology of three routers (2600 series) with GNS3 then following is the minimum hardware:

Processor= Pentium / Dual-core 2.0 (with virtualization feature)
RAM= 1 GB
OS= Windows 7 Service pack 1 or higher
For more routers and for creating the complex network labs in gns3 we define following chart for a minimum memory of single network device. when you use multiple network devices in your labs you can guess the minimum memory requirements with the following chart:

Minimun RAM for running single IOS/Router
2600 series IOS = 256MB
3700/3600 series IOS = 256 MB
7200 series IOS = 512 MB
VMware/VirtualBox Workstation= 512MB in case of XP
Tiny Care VM= 256MB (in case of older versions)
Qemu host=256MB

Idle PC value will help gns3 to consume fewer CPU resources. It’s specific to each different image or IOS.

Recommended Hardware Requirements For Gns3:

According to documentation and in view of different network engineers following is the recommended hardware requirements for simple network scenarios running with 5 to 6 routers. 

Processor= Quad core / i7 / 7th Generation
RAM= 8 GB
OS= in case of windows 64bit windows7,8,10 Or server 2012 or higher
Virtualization: virtualization extensions required.

your hardware requirements will increase, If you want to simulate the more advanced lab with many virtual devices, You have required at least 512 MB memory against single virtual Router, and it will be increment as your number of devices are increased and in case of VM/IOU its depends on their OS/IOS. In case of VMware VM running windows 7,8,10 2GB for each VM.

Cisco Server or ESXI Server Recommendations:



OS=Ubuntu 64 bit GNS3 Qemu 2.6.0 or latest Windows 8.1 GNS3 VMWare Workstation
RAM= 64GB to128GB RAM.
Quad Core Processor

Last words: GNS3 hardware requirements directly depend on your network topologies, please share the hardware which you are using for your GNS3 in comments. Thank you for visiting...!

Download Tiny Core 8 LINUX IOS for Gns3

Download Tiny Core LINUX IOS for Gns3:


TinyCore Linux is a limited Linux OS focusing on providing a base system for running different basic services. TinyCore is free and open-source software & it is normally used in virtual topologies for creating different network scenarios. You can install this IOS on windows using VMware 14 and can use it as GNS3 host. If want to learn how to use tiny core as Gns3 host you can visit here.

From here you can download Tiny core 8 IOS for your GNS3 for free. Download and install the IOS in Vmware and then use it as GNS3 host (PC)

Download Tiny Core LINUX IOS for Gns3

I hope this is helpgul for you, please share your comments in case of any issue. Thank you.!

GNS3 VMware how to use gns3 VM with VMware for TinyCore

How To Use GNS3 with vmware workstation?

In this article, I will show you how to add VMware-VMs to GNS3 labs. With new GNS3 you can use the different virtual devices with VMware in batter way like if you want to use Qemu it is better to use the Timy core VM with GMS3.

In this article, I will show you how to use VMware workstation with Gns3, for this we will follow these steps:

1. Installation of VMware
2. Creation of TinyCoreVM workstation in VMware
3. Connecting VM with Gns3
4. Configuring TinyCore VM in Gns3

Installation of VMware:

Installation of VMware the simplest step, you can download it free from internet and can install it easily by completing the simple wizard. You can want the following video regarding the installation of VMware 14 for reference.


Creation of TinyCore VM workstation in VMware:

Once you have installed the VMware now you are required  "TinyCore IOS" for creating VM in VMware. If you don't have this then you can download it free from their website or by using following links:
Download TinyCore IOS for GNS3 64bit
Download TinyCore for Gns3

Now start the VMware 14 on your PC, click on "create a new Virtual Machine" a wizard will be started.



First it will ask for type of configuration for your VM, if you are beginner you may choose typical.



In next step, you are required to locate the TinyCore IOS which you have download in previous step, for this click on browse and define the path for TinyCore IOS.


Now select the OS for your VM, in case of TinyCore you need to select Linux and Ubuntu.



Now define the VM name



Now you need to define the disk size for Qemu, and 1 GB is enough and in next step from Customized hardware select the RAM 512MB for your Qemu and finish the wizard.



Once you have created VM in vmware you may get this error while turning it on, "This host supports Intel VT-x, but Intel VT-x is disabled" for details you can visit this link.

Connecting TinyCore VM with Gns3:


Now open the Gns3, goto edit and open preferences and click on VMware VM and click on new.



Select your desire VM from List and click finished, i have select Qemu VM 8.0 which we have careate in previos steps.



now this VM will appear in "end devices "list. Drag some VM on stage with router and create topology.



Configuring TinyCore VM in Gns3:


For configure TinyCore host right click on it click on start.  Once it is loaded now click on control panel for IP configuration as shown following. Configure the tinycore with an IP address in the same subnet as of router.



Now click on network and configure the relevant IP address and other details & click Apply and then Exit.

I have assigned the following setting:

Interface: eth0

IP address: 10.1.1.2

Mask: 255.255.255.0

Broadcast: Nil

Gateway: <IP of connected router>

DNS: Nil

I hope this article is informative for you, please share your thoughts in comments. THANKS

This host supports Intel VT-x but Intel VT-x is disabled.

This host supports Intel VT-x, but Intel VT-x is disabled.


Intel VT-x might be disabled if it has been disabled in the BIOS/firmware settings or the host has not been power-cycled since changing this setting.
(1) Verify that the BIOS/firmware settings enable Intel VT-x and disable 'trusted execution.'
(2) Power-cycle the host if either of these BIOS/firmware settings have been changed.
(3) Power-cycle the host if you have not done so since installing VMware Player.
(4) Update the host's BIOS/firmware to the latest version.
This host does not support "Intel EPT" hardware assisted MMU virtualization.
This host does not support virtualizing real mode. The Intel "VMX Unrestricted Guest" feature is necessary to run this virtual machine on an Intel processor.
Module 'CPUIDEarly' power on failed.
Failed to start the virtual machine.


You find the above messages when you try to create and running VM on windows 7 8 10 with VMware 14. This message appears because you try to use the virtualization on your PC but it is disabled on it. For resolving this you are required to enable it on your PC. You can enable it using following steps:
1. Restart your PC and enter into setup/BIOS mode, for Dell PC you need to press F2 in the start for BIOS setting.
2. Once you are in BIOS, find the option of virtualization.



3. Enable it and save the setting.
4. Restart your PC and try again by creating the VM in Vmware 14, this time you will successfully create your VM.

In case of issue you can share your experience in comments, also you are having PC with Core 2 Duo Txxxx processor you may get the following message:

"This host does not support "Intel EPT" hardware assisted MMU virtualization."

This means that your processor does not support EPT virtualization but you can either use and download VMware12.5.7. This should still support the TXXXX CPU. I hope this is helpful for you, thank you for visiting.


SSTP VPN Features and advantages

SSTP VPN Features and advantages:

SSTP (Secure Socket Tunneling Protocol) is a Microsoft proprietary VPN protocol which works only on Windows based OS, it is considered secured VPN tunnel that provides a way to transport PPP-traffic through an SSL or TLS channel. Which provides transport level security with encryption, key-negotiation, and traffic-integrity checking. SSL or TLS uses TCP port 443 which allows Secure Socket Tunneling Protocol to pass through virtually all firewalls and proxy-servers but except for authenticated web-proxies.
SSTP is generally considered to be one of the most secure protocols for VPN, although it does not have the same open-source benefits as OpenVPN

How SSTP VPN works?

In SSTP a client-device can connects with server using port number 443 after having the internet access. You are required authentication on client side only; client gets server’s certificate for authentication and if it is invalid then the connection gets terminated. Once it is connected, client sends HTTPS-request as well as SSTP control packets, then PPP negotiation and after that PPP assigns IP interfaces to both ends. Now both sides are ready IP communication with each other.

Features and advantages of SSTP

SSTP VPN protocol has following advantages and features that you should consider beforehand to get the best out of it.
  • It uses the SSL port that is port number 443.
  • SSTP almost have the same advantages as OpenVPN and like bypassing NAT firewalls because of ssl port.
  • SSTP uses SSL transmissions instead of IPSec.
  • SSTP uses 2048 bits encryption & authentication-certificates.
  • SSTP can penetrate most of the firewalls.
  •  SSTP is supported by open source VPN server SoftEther.
  • SSTP is considered very secure because of the strong AES encryption.
  • SSTP supports Windows based operating systems like windows 7, 8 or 10.
  • SSTP provides Perfect Forward Secrecy.


On the other hand SSTP is a proprietary technology, SSTP is owned by Microsoft and does not have support for modern mobile and desktop OS.

PPTP vs OpenVPN | Difference between OpenVPN and PPTP


PPTP vs OpenVPN What is the difference between OpenVPN and PPTP

This article is about the difference between  OpenVPN and PPTP. Following are some important differences of  OpenVPN and PPTP.

PPTP

OpenVPN

 Point-to-point tunneling protocol (PPTP) is a VPN protocol used for fast and easy to use protocol. PPTP is a good choice if Open-VPN is not supported by a device.
OpenVPN has Highest performance, fast, secure and reliable which uses open source technology like OpenSSL-encryption and SSL v3-TLS v1. OpenVPN is recommended protocol for OS including Windows, Linux and Mac. Can be slightly slower than PPTP and introduce more overhead.

PPTP Supports Encryption level up to 128 bit session encryption-keys.


OpenVPN Supports Encryption level up to 256 bit session keys, however the session-keys can be vary. Exceptional data security when using AES-256 encryption

PPTP Uses TCP port and GRE Port Configuration.

 You can configure OpenVPN with TCP or UDP ports. Uses port 443 by default, so it looks like HTTPS traffic
·          

PPTP is Very stable and accepted by most Wi-Fi hot-spots.

OpenVPN is the Most stable and reliable even on non reliable networks, behind wireless-routers and on Wi-Fi hot-spots as well.
In PPTP the data encryption is done using the Microsoft Point-to-Point Encryption Protocol.
Where as in Data encryption is done with the OpenSSL library in OpenVPN.

Following are the supported OS by PPTP:
Windows
Mac
Android
Following are the supported OS by OpenVPN:
Windows
Mac
Android
PPTP is less secure as it uses the Basic encryption.
OpenVPN is most secure as it uses the highest encryption and will be most secure if its set to use AES-encryption instead of the weaker-Blowfish encryption.
PPTP is Fast due to lower encryption.
OpenVPN is also best performing protocol with fast speeds, even on connections with high latency and across great distance.
PPTP is old and vulnerable protocol, although integrated in-to common OS and easy to set up. But it is better to stay away from it.
OpenVPN is new and secure, although you ll need to install a 3rd party app.
PPTP is not an open source software
OpenVPN is open source software.

No additional software is required.
Typically requires downloading an extra software client

Drawbacks:
·         Rampant security flaws
·         Shouldn’t be used unless it is an only option
·         Weak encryption
·         Can be blocked easily by ISPs and networks

·         A little more difficult for non-technical users to setup without a guide and this is the one of the largest drawbacks to OpenVPN is that it isn’t always available as an option for non-technical users.
·         And because it isn’t offered by default with most operating systems, users first typically need to download an OpenVPN client-software. In addition, OpenVPN can actually be a little slower than other connection options such as L2TP/IPsec.



I hope this is informative for you, i tried to cover all aspects in this post. You can add or share your comments for improving this post. Thank you!

VPN Configuration on Gns3

Gateway of last resort is not set In Cisco Router

Gateway of last resort is not set In Cisco Router or Switch

You may notice the Line “gateway of last resort is not set” in output when you use the cisco command Show IP Route. This short article will explain that why you are getting this message.

Cisco router gateway of last resort

"Gateway of Last Resort is not set” means that there is no default route for IP packets which have no match with routing table. Gateway of last resort are routes use to avoid your router from dropping packets with unknown networks those are not exist in routing table
Routing table have the list of all known routes. Every time when a router receives a packet, router matches it with routing table entries if it present in routing table then it forward to that path and if route not present in routing table then it is forwarded to default gateway or default route.

How to set Gateway of last resort in router

You can configure or set a default gateway, or route of last resort with following commands:
  •  ip default-network    
  • ip default-gateway    
  • ip route 0.0.0.0 0.0.0.0


ip default-gateway

The ip default-gateway command is used when ip routing is disabled on Cisco-router. Following example defines the default route on router to 172.16.15.4:
ip default-gateway 172.16.15.4


Instead of ip default-gateway command, you can use ip default-network when ip routing is enabled on Cisco-router. When you configure ip default-network the router considers routes to that network for installation as the gateway of last resort on the router. Gateways of last resort selected using the ip default-network command are advertised differently depending on which routing protocol is advertise the default route. For IGRP/EIGRP to propagate the route, the network specified by the ip default-network command must be known to IGRP or EIGRP.
RIP advertises a route to 0.0.0.0 if a gateway of last resort is selected using the ip default-network command.
The default route advertised with the ip default-network command is not propagated by IS-IS and OSPF.

IP Route 0.0.0.0

Creating a static-route to unknown network is another way to set the gateway of last resort on a router. IGRP does not recognize a route advertise with static route command to 0.0.0.0. You are required to use the ip default-network command in case of IGRP. EIGRP advertise a route to network 0.0.0.0, but the static route must beredistributed into the routing protocol.
RIP routers running Cisco IOS 12.0T and later does not advertise the default route where as in earlier version it automatically create a default route 0.0.0.0.

Summary:
Use the ip default-gateway command if the ip routing is disabled on Cisco-router and Use the ip default-network and ip route 0.0.0.0 0.0.0.0 commands to set the gateway of last resort on Cisco routers that have ip routing enabled. The way in which routing-protocols advertise the default route differs for each protocol.

Quick Tip:
For setting network of last resort like use the following command:
ip default-network <IP address of gateway>

Redistribute static route into EIGRP re-distribute Static Lab

Redistribute static route into EIGRP

In an inter-network environment, normally you have a single routing-protocol for ease of controlling your network. But when you are connecting the multiple networks, branch office with each other then there may be the different routing protocol.
Route Redistribution permits routes from one routing-protocol to be advertised in-to another routing-protocol. The routing protocol which receives these redistributed-routes are normally marked the routes as external-routes. External-routes are generally less preferred than locally originated-routes.
You can redistribute routes from one routing protocol to same routing protocol, like two separate OSPF with different process ID’s.
Redistribute static route into EIGRP
Similarly you can redistribute static routes and connected interfaces into a routing protocol as well. This article is about the redistributing the static routes into EIGRP process. For simplicity and clear understanding I have designed a lab in GNS3.
Lab Objectives

We have three routers R1, R2 and R3. R1 and R3 are running with EIGRP and our objective is to redistribute the static routes from R2 into EIGRP so that these can be available at R3 as external routes.
I have configured this lab on GNS3 with following configurations:
Configurations on R2

R2(config)#interface f0/0
R2(config-if)#ip address 50.0.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface loopback 1
R2(config-if)#ip address 10.10.10.1 255.255.255.0
R2(config-if)#interface loopback 2
R2(config-if)#ip address 20.10.10.1 255.255.255.0
R2(config-if)#interface loopback 3
R2(config-if)#ip address 30.10.10.1 255.255.255.0
R2(config-if)#interface loopback 4
R2(config-if)#ip address 40.10.10.1 255.255.255.0

Configuration of static routes for not directly connected routes:
For static route configurations you are required to advertise destination network with next hop address via static route command as following:
R2(config)#ip route 150.0.0.0 255.255.255.0 50.0.0.2
R2(config)#ip route 100.10.10.0 255.255.255.0 50.0.0.2
R2(config)#ip route 200.10.10.0 255.255.255.0 50.0.0.2


Configurations on R3
R3(config)#int f0/0
R3(config-if)#ip address 150.0.0.2 255.255.255.0
R3(config-if)#no shut
R3(config)#int loopback 1
R3(config-if)#ip address 100.10.10.1 255.255.255.0
R3(config-if)#exit
R3(config)#int loopback 2
R3(config-if)#ip address 200.10.10.1 255.255.255.0
R3(config-if)#exit

R3(config)#router eigrp 10
R3(config-router)#network 150.0.0.0 0.0.0.255
R3(config-router)#network 100.10.10.0 0.0.0.255
R3(config-router)#network 200.10.10.0 0.0.0.255

Configurations on R1

R1(config)#int f1/0
R1(config-if)#ip address 50.0.0.2 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 150.0.0.1 255.255.255.0

R1(config)#router eigrp 10
R1(config-router)#network 150.0.0.0 0.0.0.255
R1(config-router)#network 50.0.0.0 0.0.0.255

R1(config)#ip route 10.10.10.0 255.255.255.0 50.0.0.1
R1(config)#ip route 20.10.10.0 255.255.255.0 50.0.0.1
R1(config)#ip route 30.10.10.0 255.255.255.0 50.0.0.1
R1(config)#ip route 40.10.10.0 255.255.255.0 50.0.0.1

Static Routes redistribution into EIGRP Configurations
For Static Routes redistribution into EIGRP you need to permit all the static routes with a route map which you want to redistribute into EIGRP. For this you are required a access-list with all IP which are going to redistribute in EIGRP.

R1(config)#access-list 7 permit 10.10.10.1
R1(config)#access-list 7 permit 20.10.10.1
R1(config)#access-list 7 permit 30.10.10.1
R1(config)#access-list 7 permit 40.10.10.1

R1(config)#route-map static-to-eigrp permit 10
R1(config-route-map)#match ip address 7

Redistribution Commands:

R1(config)#router eigrp 10
R1(config-route-map)# R1(config-router)#redistribute static route map static-to-eigrp
R1(config-route-map)# R1(config-router)#redistribute static metric 10000 1 255 1 1500 (not compulsory in case of static routes)

Testing and verification of configurations:
After the successful configurations you will find the static routes in R3’s routing table as the external routes:
Network 10.10.10.0, 20.10.10.0, 30.10.10.0 and 40.10.10.0 are the interfaces configured at R1 and after complete configuration you can find these routes in R3 routing table.
You can also perform an end to end ping for testing. Following are some other redistribution labs you can visit these as reference and learning.



UA-23728446-1