EIGRP OSPF Redistribution CCNP Route Sim
In following topology there are four router, R1, R2 and R3 are running in EIGRP AS 100. While R2’s s1/2 is running in OSPF area 24, R3’s f2/0 interface is running in OSPF area 34. In this Sim you need to redistribute OSPF into EIGRP so that they can communicate with each other. At the end of your configuration ping from R1 to Test IP 172.16.100.1 must be successful.
You can practice this simulation in GNS3 very easily; first you need to create above topology in GNS3 with following configurations. I have run EIGRP on R1, R2 and R3 and OSPF on R2 and R3 according to above diagram. In real Exam you don't have any concerned regarding routing protocols configuration you just need to redistribute OSPF and EIGPR
GNS3 Configuration:
R1 Configuration:
Router(config)#hostname R4
Step for configuration in Exam:First we need 5 parameters of the s1/2 interface i.e. (Bandwidth, Delay, Reliability, Load, MTU) for this use command.
R2#config terminal
R2(config)# router ospf 1
R2(config-router)# redistribute eigrp 100 metric-type 1 subnets
R2(config-router)#exit
R2(config-router)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500
For R3 we use the show interface fa2/0 to get these 5 parameters.
R3#show interface f2/0
R3#config terminal
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets
R3(config)#exit
R3(config-router)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500
Verification & testing:
Show ip route on R1: You will see the all other routes if you done the correct configuration also ping from R1 to 172.16.100.1 should be successful.
more CCNP Route Labs
In following topology there are four router, R1, R2 and R3 are running in EIGRP AS 100. While R2’s s1/2 is running in OSPF area 24, R3’s f2/0 interface is running in OSPF area 34. In this Sim you need to redistribute OSPF into EIGRP so that they can communicate with each other. At the end of your configuration ping from R1 to Test IP 172.16.100.1 must be successful.
You can practice this simulation in GNS3 very easily; first you need to create above topology in GNS3 with following configurations. I have run EIGRP on R1, R2 and R3 and OSPF on R2 and R3 according to above diagram. In real Exam you don't have any concerned regarding routing protocols configuration you just need to redistribute OSPF and EIGPR
GNS3 Configuration:
R1 Configuration:
R1(config)#int s1/0
R1 (config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config)#exit
R1(config)#router eigrp 100
R1(config)#network 192.168.1.0 0.0.0.255
R2 Configuration:
Router(config)#hostname R2R2(config)#interface s1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#interface s1/1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#interface s1/2
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#ip ospf 1 area 24
R2(config-if)#no shut
R2(config)#router EIGRP 100
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.1.0
R3 Configuration:
Router(config)#hostname R3R3(config)#interface s1/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#interface f2/0
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#ip ospf 1 area 34
R3(config)#router EIGRP 100
R3(config-router)#network 192.168.2.0
R4 Configuration:
R4(config)#interface s1/0
R4(config-if)#ip address 192.168.3.2 255.255.255.0
R4(config-if)#ip ospf 1 area 24
R4(config-if)#interface f2/0
R4(config-if)#ip address 192.168.4.2 255.255.255.0
R4(config-if)#ip ospf 1 area 34
After complete the above configuration you are at same stage where you need to configure this lab in exam.
We have done so much as given in exam and from now on word you have to handle this complete the configuration. Step for configuration in Exam:First we need 5 parameters of the s1/2 interface i.e. (Bandwidth, Delay, Reliability, Load, MTU) for this use command.
R2#config terminal
R2(config)# router ospf 1
R2(config-router)# redistribute eigrp 100 metric-type 1 subnets
R2(config-router)#exit
R2(config-router)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500
For R3 we use the show interface fa2/0 to get these 5 parameters.
R3#show interface f2/0
R3#config terminal
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets
R3(config)#exit
R3(config-router)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500
Verification & testing:
Show ip route on R1: You will see the all other routes if you done the correct configuration also ping from R1 to 172.16.100.1 should be successful.
more CCNP Route Labs
In this example R1 would send the packet to R2, then R2 would sent it to R4 all serial links. R1 has a route to 172.16.100.1 via its S1/0 link. The test requires that the packet choose the fastest link to the destination address of 172.16.100.1. That means R2 needs the distance command to convince itself that externally learned routes have a lower administrative distance than the OSPF learned route from R4 (OSPF AD 110, EIGRP external AD 170). Under the EIGRP 100 routing process in R2 needs this command (plus above redistribution commands) to choose routing path R1>R2>R3>R4:
ReplyDeleteR2#router eigrp 100
R2(config-router)#distance eigrp 90 105
With the distance command R2 will now place the learned route via redistribution in its routing table routing all packets destined for 172.16.100.X via its link to R3.
distance eigrp 90 105
DeleteFirst number being all internal routes, the second being all external routes
So, second use any between 90,110 are right
Further explanation...what's missing is that in the exam sim R2's s1/2 link to R4 is extremely low in bandwidth (around 64000 kbits). This slow link makes the preferred path R1>R2>R3>R4.
ReplyDeletethanks for addition :-)
ReplyDeleteR3 showing metric 100000 100 255 1 1500 but we redistributed metric 10000 100 255 1 1500. why it is like that. It would be metric 100000 10 255 1 1500.
ReplyDeletehi raz, 100000 or 10000 make no diffence in current scenario..but i also modify this to 100000. :-)
Deletethis is just reference configurations, in exam you need to configure according to interface detail.
thanks
In this sim need to configure the interface of test in R4 to see the route on R1 and have connectivity
ReplyDeleteR4:
interface loopback 1
ip add 172.16.100.1 255.255.255.0
no shut
ip ospf 1 area 24
Please remember in R2
R2#router eigrp 100
R2(config-router)#distance eigrp 90 105
bro y u use 105? what ad value it is
Deleteany number would work, as long as it is lower than the AD of OSPF, which is 110. Remember, External EIGRP Routes are AD of 170.
Delete@Anonymous,
ReplyDeleteyou could also create the loopback 1 with the 172.16.100.1 ip and then just add the command "redistribute connected subnets" under the OSPF process 1 on R4.
This will also bring the net into the ospf process
@raz,
in my gns3 lab it shows me the following:
R3#sh int fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
Hardware is Gt96k FE, address is c413.13ac.0000 (bia c413.13ac.0000)
Internet address is 192.168.4.1/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
This means for the redistribution command on R3:
router eigrp 100
redistribute ospf 1 metric 10000 100 255 1 1544
network 192.168.2.0
auto-summary
-> the 100 is the result of Delay /10
Rgds
anonymous2
one addition to the distance topic:
ReplyDeletebefore:
R2#sh ip route 172.16.100.1
Routing entry for 172.16.100.0/24
Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 64
Redistributing via eigrp 100
Advertised by eigrp 100 metric 1544 2000 255 1 1544
Last update from 192.168.3.2 on Serial0/2, 00:00:16 ago
Routing Descriptor Blocks:
* 192.168.3.2, from 192.168.4.2, 00:00:16 ago, via Serial0/2
Route metric is 20, traffic share count is 1
after:
R2#sh ip route 172.16.100.1
Routing entry for 172.16.100.0/24
Known via "eigrp 100", distance 105, metric 2195456, type external
Redistributing via ospf 1, eigrp 100
Advertised by ospf 1 metric-type 1 subnets
Last update from 192.168.2.2 on Serial0/1, 00:00:10 ago
Routing Descriptor Blocks:
* 192.168.2.2, from 192.168.2.2, 00:00:10 ago, via Serial0/1
Route metric is 2195456, traffic share count is 1
Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
Rgds
anonymous2
If you put the configurations as shown above with the loopback on R4 it will not give you redundant connections for R3.
ReplyDeleteAfter placing the configurations for R2 and R3 and running a traceroute to 172.16.100.1 from both R1 and R3 you can see that all packets go through R2 out the s1/2 int. After shutting off R2 int s1/2 and running traceroute again on R3 you can see that it has lost all connectivity and will not route through f0/2 to R4.
Also you can ping R4 from R3 without placing any configurations at all onto R3
making the configuration of R3 a waste of time. I verified OSPF neighborship and topology so there is adjacency via the f0/2 interface between R3 and R4.
So the question is why would you put the:
conf t
!
router ospf 1
!
redistribute eigrp 100 metric-type 1 subnets
!
exit
!
router eigrp 100
!
redistribute ospf 1 metric 100000 100 255 1 1500
!
end
Configurations on R3 if your only test is to ping 172.16.100.1 via R1? Or am I missing something and over thinking this??
To answer my own questions about the throughput and redundancy.
ReplyDeleteThe Loopback interface should be placed in OSPF Area 0 as it is an interface that is mimicking an external network. I placed it in Area 24 as posted earlier and this was one reason why it was unreachable when R2 s1/2 interface was shut off.
You could also place the loopback into Area 34, but you will receive LSA type 5 from R2 essentially looping traffic incorrectly for R3 to learn of the L1 interface from R4. So Loopback interface needs to be configured with: ip ospf 1 area 0
Also OSPF redistribute metric could actually be left as:
redistribute ospf 1
On R2 and R3 to give it the default K values, but as it is not a given I would do as described in the tutorial by adding the K values manually.
Last thing. The AD cost for the path was explained on July 31, 2012 by Kishore:
distance eigrp 90 109 ::
this is to advertise external EIGRP Routes with AD of 109 which is 1 less than OSPF.
R2 will be reciving routes to destined subnet via se 0/0/0 and via R3.
AD from OSPF which is via se 0/0/0 is :: 110 by default. Better AD but with lower BW.
AD from EIGRP which is via R3 is :: 170 (Ext Eigrp Route). Worst AD but with Higher BW.
Design requires us to use path with higher BW. which is through R3. So we need to tune the AD of Ext EIGRP Route (which is 170 by def) to 109 just less than OSPF AD (110)
so after this command ::distance eigrp 90 109
AD from se 0/0/0 :: 110
AD from R3 :: 109… So R2 will route the packets via R3 instead of exiting from se 0/0/0 which is connected serial Interface…
Hope this has cleared up any confusion that anyone reading this may have had.
In eigrp ospf redistribution sim – new exam takers say that they found the link between R2 & R3 is change to fast ethernet from serial link. As per them now there is no need to use the distance eigrp 105 command on R2 if the lab requirement is to use the fastest link. Please configure the lab by yourself & check we still require the distance command to use on R2. Without the distance command R2 will learn the 172.16.100.1 route from ospf area 24 with the ad value of 110. To fulfill the lab requirement we need to send the route 100.1 through R2-R3-R4 which have the fastest link. Some people don’t understand the ad value priority & thinks the fastest link is always better… configure & check by yourself then reply
ReplyDeleteHi All,
ReplyDeleteI have done all the configuration as mentioned & discussed above and attained the desired result of using the routing path R1-> R2-> R3->R4 using the distance eigrp 90 105 command.But when I do the traceroute on R1 I found that it is taking more time to travel through the desired path R1-> R2-> R3->R4 and less time to travel through R1-> R2->R4. I have used Fast Ethernet link between R2-> R3->R4 & Serial link between R1-> R2-> R4.
On R1 while pinging 172.16.100.1 using R1-> R2-> R3->R4 min/avg/max 1/9/20 for 100 packets
On R1 while pinging 172.16.100.1 using R1-> R2-> R4.min/avg/max 8/12/20 for 100 packets.
Can someone please explain me this.
Thanks in advance.
Knowledge is one that you gain by sharing.
There is some thing missing in this Tut , kindly any one can fix that issue i did same as it mentioned here but my PING is not working ... what is missing kindly update this ASAP
ReplyDeleteip ospf 1 area 24 command is not working in my gns3 , what is the issue , i m issuing the command from config-if mode
ReplyDeletemay be you hav an older IOS, but you can configure OSPF from config mode by network command..
Deletehi friends please send me latest dumps of ccnp …….
ReplyDeleteand send me vc please
i have the same issue please advise ip ospf 1 area 24 command is not working in my gns3
ReplyDeletei think you have older version of IOS, but you can run OSPF on router by following commands:
Delete(RUN THESE IN GLOBAL CONFIGURATION MODE)
router OSPF 1
network 192.168.3.0 0.0.0.255 area 24
above command is equivalent to "ip ospf 1 area 24"
Why do you need to use the metric-1 command when you redistribute from EIGRP into OSPF? Is this necessary?
ReplyDeletewhich ios is best for this lab?
ReplyDeleteyou can use any IOS, it may 2600 series or 3600 series IOS...
Deletethankzz ios c3640-jk9s-mz.124-16 works.
ReplyDeleteGreat lab
The exam question says: R4 is running OSPF and has redundant link to EIGRP network over R3 router.
ReplyDeleteSurely this mean the traffic needs to go via the primary link of R1>R2>R4. If this is the case the nere is no need for the distance configuration on R2. Or am i missing something here?
Why can you not just distribute like this on router 3
ReplyDeleteR3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets METRIC 10
or on R2
R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 100 metric-type 2 subnets
would this not ensure R3 will be chosen ?
hey bro please help me.i to run this command the it come with this error.can u tell me what is the problem ?
ReplyDeleteR1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
I don't see the error that you are reporting. If it's the whole "Gateway of last resort is not set" its because there is no gateway or default route set. for the purposes of this lab, it's not necessary.
DeleteHi Friends,
ReplyDeleteIf i shut the port s1/2 on R2, the traffic not passing via R3.
And i am not learning 172.16.100.0 /25 network on R3
OSPF status is full/bdr on R3.
Please can some one explain reason why its not going via R3.
I have configured as per above and redistributed Eigrp and ospf as per above mentioned.
Please see very very close, how it's configured R3 related to the metric redistribution.
Deleterouter eigrp 100
redistribute ospf 1 metric 100000 100 255 1 1500
network 192.168.2.0
auto-summary
IT'S THE KEY... ABOUT PATH SELECTION.
Hey!
ReplyDeleteI think the command below is missing in R4 basic config to get successiful ping.'
R4(config-if)#interface loopback 0
R4(config-if)#ip address 172.16.100.1 255.255.255.255
R4(config-if)#ip ospf 1 area 0
the same result can be achieved using the following on R2
ReplyDeleterouter ospf 1
distance 171
by doing so, OSPF route will not be prefered at all by R2 and therefore both R1 and R2 will always choose the Ext. EIGRP route ( AD = 170) as the best route and put that into their routing table. As we know the link between R2 - R4 is slow, I think we prefer R1-R2-R3-R4 , because of it's high bandwidth. Can someone comment on this?
if the network diagram and the links between R2 and R4 are as shown above then there is no need to use any distance command, because from R1 the packets will travel on a T1 line and then to R4, which is the best path and preferred, because by the time it gets to R3 it can easily get to R4 from R2. But if the link between R2 and R3 is fast ethernet (as if both routers are at the same site connected using a fast ethernet/gig link), as R4 using T1 line to connect toR2 and a fast ethernet to connect to R3, then any packets destined to R4 must gothrough R1-R2-R3-R4. for this all you have to do on R2 is:
ReplyDeleteR2# router ospf 1
distance 171
This will ensure R2 and will prefer Ext EIGRP instead of OSPF route learned via R4.
In R4 you missed" No shut" command twice..
ReplyDeleteSo this exercise was wrong since the beginning
hi all how we can take the all route in router r3 please tell me there is no backbone area of ospf.
ReplyDeletehello Sir,
ReplyDeletecan you please tell why you did not divide the delay by 10 while redistribution in R3?? i m stuck with this doubt for so long.
hello everybody,I already practiced this lsb with the following commands,
ReplyDeleteR1 Configuration:
R1(config)#int s2/1
R1 (config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config)#exit
R1(config)#router eigrp 100
R1(config)#network 192.168.1.0 0.0.0.255
R2 Configuration:
Router(config)#hostname R2
R2(config)#interface s2/1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#interface s2/2
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#interface s2/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#ip ospf 1 area 24
R2(config-if)#no shut
R2(config)#router EIGRP 100
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.1.0
R3 Configuration:
Router(config)#hostname R3
R3(config)#interface s2/2
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#interface e0/1
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#ip ospf 1 area 34
R3(config)#router EIGRP 100
R3(config-router)#network 192.168.2.0
R4 Configuration:
Router(config)#hostname R4
R4(config)#interface s2/0
R4(config-if)#ip address 192.168.3.2 255.255.255.0
R4(config-if)#ip ospf 1 area 24
R4(config-if)#interface e0/1
R4(config-if)#ip address 192.168.4.2 255.255.255.0
R4(config-if)#ip ospf 1 area 34
R2#config terminal
R2(config)# router ospf 1
R2(config-router)# redistribute eigrp 100 metric-type 1 subnets
R2(config-router)#exit
R2(config-router)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500
R3#config terminal
R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 100 metric-type 1 subnets
R3(config)#exit
R3(config-router)#router eigrp 100
R3(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500
But i entered the following command in R4.So that R1 can ping R4 ip 192.168.100.1.
R4(config)#interface Ethernet0/0
R4(config)#no sh
R4(config-if)#ip address 192.168.100.1 255.255.255.0 (it is same config with
your lab test ip 172.16.100.1 from R4)
R4(config-if)#no ip ospf 1 area 44
R4(config-if)#ip ospf 1 area 34
R4(config-if)#exit
R4(config)#do wr
Why ?,pls answers to me.It is right?