Route redistribution | RIP into OSPF | OSPF into RIP | Configuration lab :


Route redistribution has been become an integral part of IP network as the result of a growing need for disseminating certain routes across routing protocol boundaries.
What is route redistribution?

Route redistribution is used for communicating different routers running routing protocols with each other and advertises into another protocol.  By default, routers only advertise and share routes with other routers running the same routing protocol.  For example in figure you can see that we have two routing protocol RIP and OSPF running, without route redistribution R1 can’t reached to R3 and R4. In this article we shall learn how to make them communicate using redistribution.


Here are some basic configuration of all these routers.
R1(config)#int s1/0
R1 (config-if)#ip address 20.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int loop 1
R1(config-if)#ip address 11.1.1.1 255.255.255.0
R1(config-if)#int loop 2
R1(config-if)#ip address 11.1.2.1 255.255.255.0
R1(config-if)#int loop 3
R1(config-if)#ip address 11.1.3.1 255.255.255.0
R1(config-if)#int loop 4
R1(config-if)#ip address 11.1.4.1 255.255.255.0
R1(config-if)#int loop 5
R1(config-if)#ip address 11.1.5.1 255.255.255.0

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 20.0.0.0
R1(config-router)#network 11.1.1.0
R1(config-router)#network 11.1.2.0
R1(config-router)#network 11.1.3.0
R1(config-router)#network 11.1.4.0
R1(config-router)#network 11.1.5.0

R2:
Router(config)#hostname R2
R2(config)#interface s1/0
R2(config-if)#ip address 20.0.0.2 255.255.255.0
R2(config-if)#interface s1/1
R2(config-if)#ip address 30.0.0.1 255.255.255.0
R2(config-if)#no sh
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 20.0.0.0
R2(config)#router ospf 1
R2(config)#int s1/1
R2(config-if)#ip ospf 1 area 0

R3
Router(config)#hostname R3
R3(config)#int s1/0
R3(config-if)#ip address 30.0.0.2 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int s1/1
R3(config-if)#ip address 100.0.0.1 255.255.255.0
R3(config-if)#no sh
R3(config)#router ospf 1
R3(config-router)#ex
R3(config)#int s1/1
R3(config-if)#ip ospf 1 area 0
R3(config-if)#int s1/0
R3(config-if)#ip ospf 1 area 0

R4
Router(config)#hostname R4
R4(config)#router ospf 1
R4(config)#int s1/0
R4(config-if)#ip address 100.0.0.2 255.255.255.0
R4(config-if)#no shu
R4(config)#router ospf 1
R4(config-router)#ex
R4(config)#int s1/0
R4(config-if)#ip ospf 1 area 0

Before redistribution you can see in figure that in R4’s routing table there are no RIP routes, here we need to choose the best appropriate router for redistribution that is R2 (ASBR) in this case. When we redistribute RIP route into OSPF we need to define matric values for that route. Following are the commands for redistributing RIP into OSPF.


R2(config)#router ospf 1
R2(config-router)#redistribute rip subnets metric 22222


When you redistribute other routing protocol in OSPF, they will appear in the OSPF routing table as type E2 routes.





End to end ping i.e. from R1 to R4 is not success full at this step. Because we need to redistribute OSPF into RIP as follow.

R2(config)#router rip
R2(config-router)#redistribute ospf 1 metric 3

8 comments:

  1. Bro in redistribution

    R2(config)#router ospf 1
    R2(config-router)#redistribute rip subnets metric 22222 (why this metrics 22222)

    R2(config)#router rip
    R2(config-router)#redistribute ospf 1 metric 3 (why metrics 3? we used bandwidth,dly, reliability,load,MTU) so plz bro explain!!

    ReplyDelete
    Replies
    1. R2(config)#router rip
      R2(config-router)#redistribute ospf 1 metric 3

      here we redistributing OSPF into RIP and as we know that RIP metric is hub count.. OSPF metric is cost (bandwidth), now suppose these OSPF route are coming into RIP domain and in rip there is not ospf cost.. therefore we need to define hub count for OSPF routes that are redistributing into ospf. that way i use "metric 3" its mean that routes feels that these OSPF routes are the 3 hub away.
      and similarly R2(config-router)#redistribute rip subnets metric 22222
      where metric 22222 is appear in OSPF domain for rips routes..
      you can also see the above figure that on R4 have metric of 22222 for all rip routes..

      Delete
  2. R2(config)#router rip
    R2(config-router)#redistribute ospf 1 metric 3 (why metrics 3? we used bandwidth,dly, reliability,load,MTU) so plz bro explain!!


    Que locura solo cuando se redistribuye dentro de eigrp es que se debe ingresar metric bandwith, delay, reliability, load MTU)

    Ejemplo
    router eigrp 123
    redistribute ospf 1 metric 1544 2000 255 1 1500

    ReplyDelete
    Replies
    1. again please read the above comment .. when you are redistributing OSPF routes into rip it is better that you just define hub count i.e. 3 in this case ..

      bandwidth,dly, reliability,load,MTU are use in EIGRP OSPF Redistribution ..

      Delete

UA-23728446-1