What is a Cisco Access Server and how we can use terminal server with GNS3 1.1 on Windows 8.1

Configure Access Sever in GNS3 1.3.11:

Cisco access server is used to configure and manage different routers from one centralize location or from single console. Sometimes, when you have many routers in your network or topology, it is a little annoying to deal with huge number of consoles or opened terminals. Similarly working in a real Lab environment it is also difficult to change the console cable from one router to another for configuration. To resolve this hurdle Cisco access server or terminal server is best option for you. Using Cisco access server you can configure all routers in your network topology using single console terminal and without change your console cable. When you access server is configure you can simple switch or jump to another router in your network topology by pressing  Ctrl+shift+6+X from your keyboard.
Normally we use Cisco 2511 router for access server and which has several config cables coming out from a single port. All other cables can be connected to different routers in your lab.
But you can also use any other routers and cables layout as per your requirement, here we configure access server in gns3 therefore we don't required any cable and all topology and configuration will be created in Gns3.


Gns3 Labs Details:
Gns3 version:Gns3 1.1
OS version: Windows 8.1 Pro
IOS version: Cisco 3600 Series IOS or Cisco 2900 series gns3 ios

In our Gns3 topology we have four routers R1,R2,R3 and R4. We will configured R1 with Cloud as access_server from which we can configure all the router from its console. For this purpose you need to create an virtual network adapter, i am using Microsoft loop-back adapter for this purpose. We can create and configure the Microsoft loop-back adapter by following steps:
Open device manager: Right click on my computer and then click on Manage. Now right click on top and click on add legacy hardware for create MS loop-back adapter. 


Then Click next and select the option "install the hardware that i manually select from list
From devices list select the network adapter and click next:
Now from list choose Microsoft and then Microsoft KM-Test loopback adapter and click next and then finish.
Once you finished you will find  a network adapter in your network connection, assign any IP address of any class. Here i have assigned 11.11.11.1 with subnet-mask of 255.255.255.0. 
Now open your GNS3 then  from GNS3 Preferences> Gns3 servers> Local Server tab and choose the IP address of your MS loopback adapter (in our case it is 11.11.11.1) or make sure "Allow console connections to any IP address" is checked.
Now drag the cloud from gns3 devices and configure it with Microsoft loopback adapter.
You may got the error unable to create generic ethernet while connecting cloud to gns3, for troubleshooting you can click on link.

Cisco Configuration of access server for R1:

Open the R1 and perform the following configurations:
R1(config)#hostname Access_Server
Access_Server(config)#int f0/0 

Access_Server(config-if)#ip address 11.11.11.2 255.255.255.0
Access_Server(config-if)#no shut
Access_Server(config)#ip host R2 2002 11.11.11.1
Access_Server(config)#ip host R3 2003 11.11.11.1

Access_Server(config)#ip host R4 2004 11.11.11.1

Where 2002, 2003 and 2004 are console port numbers for R2, R3 and R4 respectively, you can find it by right clicking on router and then click on "change console port" .

How to Switch to other routers from access server

Once you have completed the above configuration you can switch to routers by following two ways:
  • By pressing Ctrl+shift+6+X
  • by typing router name in enable mode like "Access_Server#R3" for switching to R3 router.

Fixed: Unable to create generic Ethernet NIO Gns3 Cloud issue on Windows 7 or 8.1

Cloud NIC adapter is not working on GNS3:

Gns3 Shows this error when you try to connect router to gns3-Cloud. Cloud node is used for connecting Physical, Microsoft loopback or virtual interface to gns3. Currently there is not exact description for this error message but normally this is happen when your NIC is not initialized correctly.  

How to resolved  ” Unable to create generic Ethernet NIO”:



Complete error messageServer error [-3200] from 127.0.0.1:8000: SW1: unable to create generic ethernet NIO
OS= windows 7 32bits (Same was reported on 64 bits windows 7 & 8.1)

You can resolved or troubleshoot this error very easily in GNS3 by following the given steps. It may possible that you issue may get resolved by trying first step and you need not to go further in troubleshooting. Here are the steps for resolving this problem in gns3.
1.    Disabled and Enable the network connection associated with gns3-cloud. For this type “ncpa.cpl” in run, this will show you all NIC setting. Right click on your required one & then Disabled and Enable.
2.       Turn off the windows Firewall and check it again in GNS3.
3.       Reboot your computer. (In most cases restart works for this issue)
4.       If after the reboot you still have the same issue then check out your antivirus setting. Temporary disable your AV and check GNS3 again.

If you still have the same issue even after trying above step then please share your experience in comments. Thank you..!

How to Open a .DMG File on MAC OS X

How to Open a DMG File in Mac

A .dmg file is an Apple’s Disk Image file or a copy of a CD or DVD which is combined in one file. The OS deals this file like a physical disk. Normally OS X will automatically mount a .dmg file when you double click it, however should this fail you can manually mount an image using tools that come with the operating system.

Steps for opening a .DMG file:


  1. Double Click on .dmg file, a new windows will be open.



2. Now drag the file from left icon to applications, it will automatically open the your DMG file.

3. Similarly you can add your DMG file into applications from GO/Applications, open applications and then drag file into application. 


It will mount your DMG file.


Alternative method for open .dmg file on MAC X:

1.      Click on "Disk Utility" from your Applications list as mention above from GO/Application. It should be in a folder called Utilities.
2.      Click "Mount" from top and select the .dmg file you want to open. Once mounted it will appear on your desktop as an icon.

3.      Double-click on the icon (appear in left side) to open it.

How to eject DMG file:

You can eject the .DMG file in different ways:

1. Right click on mount file and then click on Eject.



2. Go to desktop device and then click on little arrow for ejecting .dmg file.



Vm Windows 10 is not accessible from GNS3 Problem with Virtual Machine is not getting IP from DHCP in GNS3

How to Connect Windows 10 Virtual Machine with GNS3 1.3.9:

You can see the following Video for connecting VM to router in GNS3:




If you are having difficulty while connecting a VM to GNS3 you may check the following:


1. Open the VirtualBox, goto adapter setting and select 'Not attached' 
2. If the ping from router to VM machine is not successful then turn off windows 10 firewall.
3. if you want to give the IP address to VM via DHCP configured on gns3 router then make sure you have disable all other DHCP in the network.



In case of any issue, you can ask question in comment.

DHCP lab in GNS3 | How to Configure DHCP on Cisco Router

Cisco DHCP Configuration | How to assign automatic IP address from Cisco Router:

In this article I will show you how to configure and enable DHCP (Dynamic Host Configuration Protocol) on Gns3 router. For this lab I have Create the following lab in which I have configure a router (DHCP Server) as DHCP server where as I used the two DHCP clients which will obtain the IP address automatically from DHCP server. These DHCP clients include a router (which is configured like a PC) and a VM machine.  You can visit How to connect windows VM to Gns3 & installation of windows 10 on Virtualbox for more detail.



Following configuration are required for making the Router as DHCP server.

DHCP server (R1) Configuration:
R1#enable
R1#Configure t
R1 config)#ip dhcp pool ipranges
R1(dhcp-config)# network 100.1.11.0 255.255.255.0
R1(dhcp-config)#dns server 100.1.11.1
 R1(dhcp-config)#default-router 100.1.11.1
R1(dhcp-config)#lease 10 (this command will set the IP lease for 10 day, view more Cisco Commands)

How to exclude the IP addresses from DHCP range


R1(dhcp-config)#ip dhcp excluded-addresses 100.1.11.20 100.1.11.31

Following are the configuration required on router which will act as DHCP client.

PC2 Configuration:
PC2#enable
PC2#Configure t
PC21#no ip routing
PC2#inf f0/0
PC2#ip address dhcp
 PC2#no shutdown

VM win 10 DHCP client configurations:

Simple power on the VM host in DHCP and set the network adapter setting to obtain the IP automatically. Check the following images:




How to test DHCP configurations:

On DHCP server use the following command for confirming DHCP configurations
show ip dhcp binding
Following will be the output in our case.


Other command that you can use is:
show DHCP neighbor.

GNS3 Tutorials for beginners | How to getting start with GNS3

GNS3 is one of the famous software for simulating the network devices. It is important for a networks Engineer or networks profession that he can create and simulate different network scenarios using GNS3.



This article is divided into different sections and design for both beginners and advance level GNS3 users.

GNS3 Tutorial for begginers:

If you are newer to GNS3 you can start working on GNS3 with the following tutorials:







GNS3 Labs & Tutorials

Following are some network labs that you can create with GNS3.

Cisco Route filtering




Use Juniper on GNS3

GNS3 Tutorials for CCNA:

Following are some gns3 labs which are useful for CCNA preparation.



Basic OSPF configruations


GNS3 video tutorials

Create Vlan with GNS3



Gns3 installation on ubuntu 



CCDA Intro freeTraining and tutorials 



GNS3 Gerneral issue and troubleshooting:


Cisco Basic Commands list for beginners | Cisco command levels EXEC Modes

Cisco IOS command level and their Basic Commands:

This article has basic Cisco commands, for more commands and details you can visit Cisco.com.

What are Cisco command levels EXEC Mode and how to access them:

With Cisco command levels EXEC Mode you can control user privileges. These user privilege controls can be given through password.  There are three command levels in all Cisco IOS devices. In each command level you have specific privileges and control. These commands Level are as under:
  •  User Mode
  • Privileged EXEC  Mode
  • Global configuration Mode

Cisco User Mode Cisco:

In user EXEC mode you can execute limited array of show commands, basic reachability tests, such as ping and traceroute, as well as other ways of viewing configurations and status info of a Cisco device without the ability to make changes. This command level is represented by symbol “>”, by using command you can “enable” you can go to next mode i.e. privileged EXEC mode.

Cisco Privileged EXEC Mode

Privileged EXEC mode is represented by symbol “#”.

This mode is for users that have been some admin privileges and need to make changes, but in this mode most of commands are related to view/show configurations and debugs.
In privileged EXEC Mode most of command show the status of cisco devices, module and startup, running configurations and configurations of different protocols.

Cisco Global Configuration Mode

This mode is for administrator and power user, from this mode you can configure your Cisco device can configure different Protocols. Some of common commands for configurations of this mode are as under.

You can access or go to global configuration mode by using command “configure terminal” when you are in Privileged EXEC mode.
R1>
R1>enable                                          Entering into Privileged EXEC Mode
R1#configure terminal                   Entering into Global Configuration Mode
R1(config)#

Note: In this article all Cisco commands are represented with purple color.

Example of Commands in Privileged EXEC Mode:

How to Check the IOS/hardware version of Cisco Device:

R1#Show Version 
Show version command will displays the configuration of the system hardware, the IOS version, and the names and sources of configuration files and the boot images. This command also displays information about how the system was last started and how long the router has been running since that start.

How to check all running configurations of Cisco Device:

Show running-config
This command will show all the configuration which are configure on Cisco device. You view output of show running-config

How to check the vlan details on Cisco:

Show Vlan
Click here to see the Outputof show vlan

How to check detail of specific interfaces on Cisco:

Show interface <interface name>
Command Example: show interface f0/0 (this command will show the detail of interface fastEthernet 0/0) 

How to check syslog errors:

show logging
show logging command displays the state of syslog error and event logging, including host addresses, and whether console logging is enabled. View output of show logging

How to check running process on Cisco Device:

show Processes 
This command will displays information about the active processes.

How to check the memory used by running process on Cisco:

show Processes memory
This command will displays the amount of memory used. See
output of Show processes memory.

How to check Routing table on Cisco Router/Switch:

show ip route
Above command will show all dynamic and static routes on Cisco Device. A output of show ip route.
show ip route OSPF
Command will show all OSPF routes.
show ip route RIP
Command will show all RIP routes.
Show ip route EIGRP
This command will show all EIGRP routes.

How to check all interfaces details:

show interfaces
This command displays statistics for the network interfaces. Output of this command include following details
         i.            UP/down state of interface
       ii.            MAC Address
      iii.            IP address
     iv.            MTU ,BW Delay, duplex type of interfaces
       v.            Queueing strategy
     vi.            Packet send/received
Click here to see the Outputof show interfaces

How to check the status of all interfaces on Cisco:

Show ip interface Brief
This command will show you the IP addresses, interfaces status (up/down), protocol status (up/down), you can view output of Show ip interface Brief from here.

Check neighbors detail and routing information | Cisco CDP commands    

 show cdp interface   
  show cdp neighbors [Detail]   
  show cdp entry Router 
 Ip domain-Lookup nsap    
 Show hosts    

Some other Examples of show commands:

Following are some others show command which are self-explanatory you can try these command on your Cisco device and view their output.
Show clock
Show controllers
Show mac-address-table 
Show memory
Show privilege
Show protocols
Show startup-config
Show Flash 
Show spanning-tree


Examples of Global configuration Commands:

 To enter in Global configuration mode type: config terminal. Global configuration mode is often used to configure the network Commands.

Set hostname of Router:

Router(config)#hostname <distinguished name>
Command Example: Router (config)# hostname R1 (This command will set the router name to R1)

How to set banner message:

banner motd <banner start identification> banner message <banner end identification>
Command Example:
banner motd #Unauthorized access to this device is prohibited!#    
Above command with set the banner to "Unauthorized access to this device is prohibited" 

How to set IP address to Cisco interface:

Router(config)#  Interface <port number >
Router(config-int)# ip address <ip address number>
IP address Command Example:
 Router(config)#interface f0/0
Router(config)# ip address 176.16.32.1 255.255.255.0
(This will set the IP address 176.16.32.1/24 to interface f0/0)
How to up/on the Cisco router interface:
Router(config)#interface f0/0
Router(config-int)# no shutdown 
(above command will change the status of interface fo/o to active/up/ON)

How to set the interface speed:

Interface console type the following commands for configuring interface speed.
switch(config-if)# speed{10|100|auto

R1(config)#interface f0/1
R1(config-if)#speed 100
Above commands will configure the speed of 100MBs to interface f0/1.

How to set enable password on Cisco:

Router(config)#  Enable Password <password>
Enable password Command Example:
 Router(config)# Enable Password Cisco
(This will Establishes a enable password to Cisco)

How to set Telnet password on Cisco:

Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password cisco
(Above command will create a Telnet password to Cisco)

Cisco IP routing Commands:

How to set the static routing:   
Router(config-router)#ip route [destination_network] [mask] [next-hop_address
Static route command example:
Router(config-router)#ip route 210.22.22.2 255.255.255.0 192.168.0.1
Above command will set a static route for network 210.22.22.0. See static routing on gns3.

How to set the default route on Cisco Router    

Router(config)#ip default-network< network number >   
Command Example: ip default-network 192.168.1.1

How to configure dynamic routing with Rip on Cisco:

Router(config)#Router rip    
Router(config-router)#Network <Network ID> 
Router(config-router)#Network 192.168.1.0
See more for configuration command example of RIP in Cisco from here.  

How to configure OSPF on Cisco:

Router(config)#Router ospf process ID
Router(config-router)#Network <Network ID> <mask> area <area ID>

Router(config)#Router ospf 1
Router(config-router)#network 10.0.0.0 0.0.0.255 area 0
Above command will advertise the network 10.0.0.0/24 in area 0.

How to configure access-list on Cisco:

Access-List <access number> {permit | deny}  <IP address to block>

for more details Access list in Cisco

Cisco Switching Commands:

How to crate Vlan on Cisco: 
switch(vlan)# vlan <vlan-num> name <vlan name>
 switch(vlan)# vlan 10 name marking
Above command will create vlan 10 with name marketing.
How to set access port: 
switch# configure teriminal 
switch( config)# interface fo/o
 switch(config-if)# switchport mode access 

How to assign vlan to interface in Cisco:
switch( config)# interface <interface name/number>
switch(config-if)# switchport access vlan <vlan-num> 
 Command Example:
switch( config)# interface  f0/0
switch(config-if)# switchport access vlan 10
Above command will add interface f0/0 to vlan 10.

 How to create trunk port: 

After selecting the interface mode type the following commad.
switch(config-if)# switchport mode trunk 

How to allow the specific Vlans on Trunk Port:

switch(config-if)# switchport trunk allowed vlan < vlan-list>


Cisco Daily used commands:

Cisco Connectivity Test Commands:

Ping host name / IP address    
R1> ping 10.0.0.1
traceroutehostname / IP address of destination
R1# traceroute 192.168.1.1

How to go back to previous command level: (From Global Configuration to privileged EXEC or User  mode):
1.       You can use command “Exit” or “end” for exiting the current EXEC mode, but if you want to go back to privileged EXEC  Mode from any mode simple hit the “Ctrl+Z” from keyboard.




In this article I have combine some of common and basic commands, if you think that there are some basic/important commands are missing here then please comment & I will update it accordingly. Thank you for reading it.


Cisco Static Routing Lab on GNS3 | Static Routes with GNS3

How to configure the static routes on GNS3

 Static routing is a core technology that any network engineer must understand.  With static Routing you can configure your network without using any dynamic routing protocol like RIP, OSPF etc. Commonly static routes are used for floating routes and a default route. A well designed network should have very few static routes because when you configure a static routes and in case of network changes, you’ll then potentially need to reassess and reconfigure the static route to ensure network connectivity.
With static routes, for successful IP communication it is necessarily you configure bi-directional static routes on each router. Consider the following figure, suppose you want to access R3 from R1, in such case you need two static routes one from R1 to R3 and other R3 to R1.
Static routing configuration is very simple and easy, you just need to advertise the remote network with defining the next hope address. Syntax of static route Cisco command is as under:
Router(config)#ip route <destination network> <mask> <next hope address>
Learn more Basic Cisco commands from here.


In above Gns3 lab you  have three routers on which we will configure routing using static routes. All required configuration are as following, you all also download the full configurations of these routers from links which are given under the configuration of each router.


R1 Configuration:
On router R1 one we have one directly connected network (11.11.11.0/24) and two remote networks 22.22.22.0/24 &  33.33.33.0/24. For static routing you need to configure two static routes for remote network and next hope address will interface f0/0 of R2 which have the IP address 11.11.11.2. Next hope address is like a gateway and IP address of neighbor router which is connected to remote network, if you want to access R3 from R1 you will access it through next hope address 11.11.11.2. 
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address 11.11.11.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ip route 22.22.22.0 255.255.255.0 11.11.11.2
R1(config)#ip route 33.33.33.0 255.255.255.0 11.11.11.2
Download R1 configuration
R2 Configuration:
On router R2 we have two directly connected network 22.22.22.0/24 &  11.11.11.0/24 and remote network 33.33.33.0/24. Therefore you need to configure the only static route for 33.33.33.0/24 with next hope address 22.22.22.2.

R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 11.11.11.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface f1/0
R2(config-if)#ip address 22.22.22.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#ip route 33.33.33.0 255.255.255.0 22.22.22.2
R2(config)#exit
R3 Configuration
Remote Network=11.11.11.0/24
Directly connected networks=22.22.22.0/24 &  33.33.33.0/24
Next hope address= 22.22.22.1

R3#configure terminal
R3(config)#interface f0/0
R3(config-if)#ip address 22.22.22.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 1
R3(config-if)#ip address 33.33.33.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#ip route 11.11.11.0 255.255.255.0 22.22.22.1
R3(config)#exit

Download R3 configuration

After the successful configuration show ip route on R1 will have the following output.


Cisco CLI Password Recovery Steps How to recover the router/switch password if you forget it

How to reset password of Cisco 2600, 3600,7200 series routers

Passwords are often configured on Cisco routers for security purposes and for unauthorized access. This password can be forgotten and you may need to be reset the password to access to the router. The process for recovering a password may varies from platform to platform, but each procedure follows the following basic steps:

Configure the router to boot up without reading the configuration memory (nonvolatile RAM, or NVRAM):


If we forget to enter the privileged mode password, then we'll shut down the router and reboot! Then quickly press [Ctrl + Break] key to interrupt the boot process of the router, it will enter you into rommon mode. This can be done without a password if you are in test system mode.

In this mode set the configuration register to 0x2142, which would make the router does not read NVRAM configuration file at boot time. And then restart the router!
Command is as follows:
rommon 1> confreg 0x2142 // change the configuration register is 0x2142
rommon 3> reset // restart the route or use the command reload



Then reboot the router will go directly to the setup configuration mode, use [Ctrl + C] or answered "n",
Exit setup mode! Then we enter the global mode to reset the password privileged mode.
Command is as follows:
Router> enable // privileged mode
Router # configure terminal // enter the global mode

Router (config) #enable password 1234 // reset the password of command


Cisco Interface and Line Protocol Status description | what are Line Protocol status Down/UP means

Cisco interface status description | Description of Show IP int brief command status:




You can check the Cisco interfaces with command “show ip interface brief”. The interface and line protocol status output gives information related to the physical status of the interfaces, an example of output is as shown above in figure.

When an interface is operating properly, there is only one possible status output. Following are the all possible status of interfaces.

Interface status is up, line protocol is up:

This status shows that interface is OK with physically and configured protocol is also working fine.

Interface status is down, line protocol is down

This state indicates a physical interface problem. The interface may be administratively shut down, a situation that could cause both ends to go down. To bring an interface up, use the no shutdown command under the interface configuration mode.

Interface status is  up, line protocol is down

This state means that interface is physically up but there is some protocol mismatch, attributed to a clocking or framing problem.  To resolve this issue you need to check out your protocol/keepalive configurations.

 Interface status is administratively down, line protocol is down

This state indicates interface is shutdown by administrator by using no shutdown command under the interface configuration mode. To bring the interface up, use the no shutdown command under interface configuration mode.

Interface status is up, line protocol is up (looped)

This status shows that a loop exists in the network. This problem could be associated with an existing loopback interface.

Interface status is up, line protocol is down (disabled)


This state often indicates a hardware problem and may be associated with a service provider company problem.
UA-23728446-1