IS-IS configuration on Gns3:

In this IS-IS tutorial i will shortly discuss IS-IS and create a simple IS-IS lab in gns3.
What is IS-IS?
Intermediate System To Intermediate System (IS-IS), is a link-state routing protocol. IS-IS is more efficient, in case of router memory and more flexible then OSPF. There are backbone area in IS-IS but there are L2 routers, in IS-IS there are three types of routers, L1 L2 and L1/L2 router.
  1. What is L1 Router: L1 is a router which maintain routing database for its own area.
  2. What is L2 Router: L2 is Like Backbone router as in OSPF, just knows about the route that are injected in that area. Normally L2 router is connected to all areas in network.
  3. What is L1/L2: These router knows about its area routes and L2 routes (backbone) and all routing information of other L1/L2 routers.
How IS-IS works?
  • All L1 Router finds the Best way to their L1/L2 router
  • L1/L2 find path to backbone L2 routers, there SPF runs two time in IS-IS
What is NSAP address?
IS-IS use the NSAP address for communication. OSI Use CLNP (Connectionless Network Protocol) address like IP in TCP, when you assign these address to router is called NSAP address, also called Net address. NSAP can be up to 20 bytes. NSAP have 5 sections, cisco use only three to implement IS-IS.
IS-IS Configuration:
Create and configure the topology as under.







R1 Configuration:


 R1(config)#  interface Loopback1
 R1(config-if)#  ip address 192.168.0.1 255.255.255.0
 R1(config-if)#  ip router isis
 R1(config-if)#  interface Loopback2
 R1(config-if)#  ip address 192.168.1.1 255.255.255.0
 R1(config-if)#  ip router isis
 R1(config-if)#  interface Loopback3
 R1(config-if)#  ip address 192.168.2.1 255.255.255.0
 R1(config-if)#  ip router isis
R1(config-if)#  interface Loopback4
R1(config-if)#  ip address 192.168.4.1 255.255.255.0
R1(config-if)#  ip router isis
R1(config-if)# interface FastEthernet0/0
R1(config-if)#  interface Serial1/0
R1(config-if)#   ip address 1.1.1.1 255.0.0.0
R1(config-if)#   ip router isis
R1(config-if)#  isis circuit-type level-1

R1(config-if)#  router isis
R1(config-router)#  net 49.0001.1111.1111.1111.00
R1(config-router)#  is-type level-1

R2 Configuration:

R2(config)# interface Serial1/0
R2(config-if)# ip address 1.1.1.2 255.0.0.0
R2(config-if)# ip router isis
R2(config-if)# serial restart-delay 0
R2(config-if)# isis circuit-type level-1
R2(config-if)# interface Serial1/1
R2(config-if)#  ip address 2.2.2.1 255.0.0.0
R2(config-if)#  ip router isis
R2(config-if)# isis circuit-type level-2-only

R2(config-if)# router isis
R2(config-router)# net 49.0001.2222.2222.2222.00
R2(config-router)#  summary-address 192.168.0.0 255.255.248.0

R3 Configuration: 

R3(config)# interface Serial1/0
R3(config-if)# ip address 2.2.2.2 255.0.0.0
R3(config-if)# ip router isis
R3(config-if)# isis circuit-type level-2-only
R3(config-if)# interface Serial1/1
R3(config-if)# ip address 3.3.3.1 255.0.0.0
R3(config-if)# ip router isis
R3(config-if)# isis circuit-type level-2-only

R3(config-if)# router isis
R3(config-router)# net 49.0020.3333.3333.3333.00
R3(config-router)# is-type level-2-only
R3(config-router)# summary-address 10.0.0.0 255.255.0.0 level-1-2

R4 Configuration:

R4(config)# interface Loopback1
R4(config-if)#ip address 10.0.1.1 255.255.255.0
R4(config-if)# ip router isis
R4(config-if)#interface Loopback2
R4(config-if)#ip address 10.0.2.1 255.255.255.0
R4(config-if)# ip router isis
R4(config-if)#interface Loopback3
R4(config-if)#ip address 10.0.3.1 255.255.255.0
R4(config-if)#ip router isis
R4(config-if)#interface Loopback4
R4(config-if)#ip address 10.0.4.1 255.255.255.0
R4(config-if)#ip router isis
R4(config-if)#interface Serial1/0
R4(config-if)# ip address 3.3.3.2 255.0.0.0
R4(config-if)#ip router isis
R4(config-if)# isis circuit-type level-2-only

R4(config-if)#router isis
R4(config-router)#net 49.0022.4444.4444.4444.00







IS-IS Verification commands:

R#showip route
R#show clns neighbors
R#show clns interface
Summaryzation:







 Related Books:
Complete IS-IS Routing Book
UA-23728446-1