ICND1 Practice LAB with RIPv2 SIM on GNS3

Configure different passwords and RIP on Cisco Router (ICND1 100-101):

This is most basic and simple lab for preparing ICND1 exam, which will test your skills related to different password configurations and RIPv2 on Cisco router.
You need to complete the configuration on newly installed router “Florida” in below network-diagram, RIPv2 is running on other router so you need to complete following configuration for making communication possible among Florida and newyork router:
  1. Set the name of router to Florida
  2. Set the enable-secret password of Florida to icnd1
  3. Set the global configuration password to icndpass
  4. Configure vty password (telnet) to ICND1VTY
  5. Assign the first useable IP address to Ethernet interface Fa0/0 from subnet 192.168.1.0/27 
  6. Assign the last IP address to serial interface S1/0 from subnet 200.1.1.128/28 
  7. Advertise above two subnets via RIPv2 routing protocol on Florida.

Solution:
If you want to practice this lab in GNS3 then you can download router (newyork) configurations  from here and can complete the remaining lab according to following configurations.
1. Change Host name of Router to Florida:
R1#enable
R1#config t
R1(config)#hostname Florida

2. Set the enable-secret password of Florida to icnd1:
Florida(config)#enable secret icnd1

3. Set the global configuration password of router:
Florida(config)#line console 0
Florida(config-line)#password icndpass
Florida(config-line)#login
Florida(config-line)#exit
4. Configure vty password (telnet) of router:
Florida(config)#line vty 0 4
Florida(config-line)#password ICND1VTY
Florida(config-line)#login
Florida(config-line)#exit

5. Configure Ethernet interface f0/0 of Router:
For assigning the first useable IP address to Ethernet interface from subnet 192.168.1.0/27 you need to find subnet-mask and IP ranges (increment):
Subnetting for Class C address
Bit# in 4th octet
25
26
27
28
29
30
31
32

IP ranges/ increment
128
64
32
16
8
4
2
1


Since the first three bits are ‘1’ or "on" in 4th octet for given 192.168.1.0/27 and we know that the default subnet-mask for class-C is 255.255.255.0 you can find the subnet-mask for this subnet by adding first three bits i.e. 128+62+32=224 so
Subnetmask=255.255.255.224 
From above table you can find that IP range for /27 is 32 so we have following subnetwork for this subnet with a difference of 32:

Subnetwork1= 192.168.1.0 to 192.168.1.31
Subnetwork2= 192.168.1.32 to 192.168.1.63
.
.
.
.


Our give subnet belong to Subnetwork1= 192.168.1.0 to 192.168.1.31 so we have
Subnet ID = 192.168.1.0
Broadcast address=192.168.1.31
Useable IP range= 192.168.1.1 to 192.168.1.30

From above calculation we have the first useable IP address 192.168.1.1 and subnet-mask 255.255.255.224 so let assign this IP address to router interface:

Florida(config)#interface f0/0
Florida(config-if)#ip address 192.168.1.1 255.255.255.224
Florida(config-if)#no shu


6. Configure serial interface s0/0 of Router:
For finding the last IP address for 200.1.1.128/28 you can use the following table:
Subnetting for Class C address
Bit# in 4th octet
25
26
27
28
29
30
31
32

IP ranges/ increment
128
64
32
16
8
4
2
1


128+62+32+16=240
By adding the first 28 bit you can get the subnet-mask= 255.255.255.240
For find IP last IP address you need to have the all useable IP address for subnet200.1.1.128/28, with /28 you have the following sub-network with increment of 16.
Subnetwork1=200.1.1.0
Subnetwork2=200.1.1.16
Subnetwork3=200.1.1.32
Subnetwork4=200.1.1.48
Subnetwork5=200.1.1.64
Subnetwork6=200.1.1.80
Subnetwork7=200.1.1.96
Subnetwork8=200.1.1.112
Subnetwork9=200.1.1.128 to 200.1.1.143
Subnetwork10=200.1.1.144

From above calculation we find that our network belong to Subnetwork9=200.1.1.128 to 200.1.1.143 with following details:
Subnet ID= 200.1.1.128
Broadcasar Address= 200.1.1.143
Useable IP addresses= 200.1.1.129 to 200.1.1.142

So last IP address is 200.1.1.142 and subnet-mask is 255.255.255.240

So configuration for serial interface is as following:

Florida(config)#interface s1/0
Florida(config-if)#ip address 200.1.1.142 255.255.255.240
Florida(config-if)#no shut

7. Configure RIPv2 on router:

Florida(config)#router rip
Florida(config-router)#version 2
Florida(config-router)#network 192.168.1.0
Florida(config-router)#network 200.1.1.128

You can test your configuration by ping from florida-router to 10.1.1.10 which should be successful.


Test you ICND1 Skill by Taking ICND1 Quiz Questions and Answers 

No comments:

Post a Comment

UA-23728446-1