IPv6 OSPF Virtual Link Sim configuration on GNS3:

IPv6 OSPF Virtual Link CCNP Route Sim
Question
Route.com is a small export company that has an existing enterprise network that is running IPv6 OSPFv3 for process 1. Currently OSPF is configured on all routers. However, R4′s loopback address (FEC0:44:4) cannot be seen in R1′s IPv6 routing table. You are tasked with identifying the cause of this fault and implementing the needed corrective actions that uses OSPF features and does no change the current area assignments. You will know that you have corrected the fault when R4′s loopback address (FEC0:44:4) can be seen in the routing table of R1.








Note: To gain the maximum number of points you must remove all incorrect or unneeded configuration statements related to this issue.
Step for Configuration:

This lab is for testing your OSPF virtual-link concepts. And need to configure all routers with correct virtual-link commands.

1. you need to short out the wrong virtual-link configurations that you will find on R3 & R4 i.e.

area 54 virtual-link 4.4.4.4
area 54 virtual-link 3.3.3.3
First remove these command and add the correct one.
since i have simulate this lab in GNS3 for exam's practice that way first i have configured lab with wrong configuration as you will find in real exam in GSN3 configuration section and in Real exam section i correct all incorrect configurations and add with right configuration.

GNS3 configuration:
Create this lab in GNS3 with following configuration, after these configurations you can start real lab configuration as you need to complete in exam.

R1 Configuration:
R1(config)#ipv6 unicast-routing
R1(config)#interface Loopback1
R1(config-if)# ipv6 address FEC0:11::1/64
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#EXIT
R1(config-if)#interface FastEthernet1/0
R1(config-if)#ipv6 address FEC0:1::1/64
R1(config-if)#no shut
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#exit
R1(config)#ipv6 router ospf 1
R1(config-rtr)#router-id 1.1.1.1
R2 Configuration:
R2(config)#ipv6 unicast-routing
R2(config)#int loopback 1
R2(config-if)#ipv6 address fec0:22::2/64
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#EXIT
R2(config-if)#interface FastEthernet1/0
R2(config-if)#ipv6 address FEC0:1::2/64
R2(config-if)#no shut
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#exit
R2(config-if)#interface serial2/0
R2(config-if)#ipv6 address FEC0:2::1/64
R2(config-if)#no shut
R2(config-if)#ipv6 ospf 1 area 11
R2(config-if)#EXIT
R2(config)#ipv6 router ospf 1
R2(config-rtr)#router-id 2.2.2.2
R3 Configuration:
R3(config)#ipv6 unicast-routing
R3(config)#int loopback 1
R3(config-if)#ipv6 address fec0:33::3/64
R3(config-if)#ipv6 ospf 1 area 11
R3(config-if)#EXIT
R3(config-if)#interface FastEthernet1/0
R3(config-if)#ipv6 address FEC0:3::1/64
R3(config-if)#no shut
R3(config-if)#ipv6 ospf 1 area 54
R3(config-if)#exit
R3(config-if)#interface serial2/0
R3(config-if)#ipv6 address FEC0:2::2/64
R3(config-if)#no shut
R3(config-if)#ipv6 ospf 1 area 11
R3(config-if)#EXIT
R3(config)#ipv6 router ospf 1
R3(config-rtr)#router-id 3.3.3.3

Follow virtual-link configuration are wrong i have added these because in real exam you will find such wrong configuration and you need to removes these and need to configure R2 & R3 for virtual-link. Also in exam configuration i shall removes this area 54 virtual-link 4.4.4.4 command from R3 so that all routers can communicate with each other.
R3(config-rtr)# area 54 virtual-link 4.4.4.4
R4 Configuration:
R4(config)#ipv6 unicast-routing
R4(config)#int loopback 1
R4(config-if)#ipv6 address fec0:44::4/64
R4(config-if)#ipv6 ospf 1 area 54
R4(config-if)#EXIT
R4(config-if)#interface FastEthernet1/0
R4(config-if)#ipv6 address FEC0:3::2/64
R4(config-if)#no shut
R4(config-if)#ipv6 ospf 1 area 54
R4(config-if)#exit
R4(config)#ipv6 router ospf 1
R4(config-rtr)#router-id 4.4.4.4

Configuration required in Exam:


In this lab you need to configure virtual link for area 11 so that end to end communication can be possible.
Step-1:
Show Run on R1, R2 ans R3, and check the virtual links commands, if you found any of router please remove these first. Also note the router-ids and ospf process ID. In real exam IP addresses, OSPF process ids and area ids may be change, so you need to figure out the exact values by using show run.
For example in R3 configuration you found area 54 virtual-link 4.4.4.4 which is unnecessary. 

So please remove this.  You need to make the virtual link on R2 & R3. We create virtual links when some OSPF area is not physically connected with backbone area (Area 0). The area through which you configure the virtual link is known as a transit area. Routers R2 and R3 are belonging to transit area that way need to add commands on these routers.

R4#configure terminal
R4(config)#ipv6 router ospf 1
R4(config-rtr)#no area 54 virtual-link 3.3.3.3

Step-2:
Complete the virtual links configurations on R2 & R3.

R3>enable
R3#configure terminal
R3(config)#ipv6 router ospf 1
R3(config-rtr)#no area 54 virtual-link 4.4.4.4 
R3(config-rtr)#area 11 virtual-link 2.2.2.2
R2>enable
R2#configure terminal
R2(config)#ipv6 router ospf 1
R2(config-rtr)#area 11 virtual-link 3.3.3.3
R4>enableR4#show running-config

You will see a wrongly configured virtual-link command. To get full mark we have to disable this command:
Verification:
After configuration use command “Show IPv6 route” on R1, if you found the R4 route in routing table its mean you have done this lab successfully. And ping from R1 to R4 should be successful.



Important Tip: Please don’t forget to use IPV6 in every command e.g.
Show IPV6 route, IPv6 router ospf 54 etc.
CCNP Route Labs

15 comments:

  1. nice work.. i got this lab in exam with same IP addresses.

    ReplyDelete
    Replies
    1. their contributions are also valuable

      Delete
  2. I know you guys will get made at me for not being able to troubleshoot my own problem here but really have tried. I keep getting this error when I cut and paste in the initial configs above and cannot figure out what I should do different.

    %OSPFv3-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from FEC0:3::1, FastEthernet0/0

    ReplyDelete
  3. chk same lab in u tube , they guy done it very well

    http://www.youtube.com/watch?v=EGmNYrzCh5s&list=UU41WdYdEvpUnfvlgucIEIIA&index=14&feature=plcp

    ReplyDelete
  4. this error will appear becaouse os the command "area 54 virtual-link 4.4.4.4" which been add to R3

    try to use the command "no area 54 virtual-link 4.4.4.4" on R3 - and this command will be just disappear :)

    i hope i could help you

    ReplyDelete
  5. ipv6 unicost-routing command wont work for me in gns3 any ideas?

    ReplyDelete
    Replies
    1. try some latest IOS for your router, may be you dont have the IPV6 support in your current IOS.

      Delete
    2. That's because it's misspeled. It should be: ipv6 unicAst-routing.

      Delete
  6. unicast not unicost sorted

    ReplyDelete
  7. I have a question. Why there is no need to put the virtual-link command on router R4? I see, it is running, but how come the route was propagated all way thru?
    Thanks!

    ReplyDelete
    Replies
    1. The virtual link over Area 11 (between R2 and R3) makes Area 54 virtually connected to Area 0 (the backbone area). This is a basic OSPF rule: "All areas should be connected to the backbone area."

      Delete
    2. virtual link are created between two Abr (AREA BORDER ROUTER)

      Delete
  8. Hi i use ios c3640-jk9s-mz.124-16 and configuring on
    R1: ipv6 router ospf 1
    R1: area 0 ?
    authentication Enable authentication
    default-cost Set the summary default-cost of a NSSA/stub area
    nssa Specify a NSSA area
    range Summarize routes matching address/mask (border routers only)
    stub Specify a stub area
    virtual-link Define a virtual link and its parameters

    what do i need to configure or do i need another ios?
    Thankzz

    ReplyDelete
  9. when i create a virtual link for area 11 and i remove the incorrect virtual link in area 54, i cant see the loopback int of router 4. but if i leave the virtual link in area 54 i can see it after creating a virtual link in area 11. any problem? i downloaded the lab in digitaltut.com.
    kindly help, i have exams tomorrow, 21-Mar-2014

    ReplyDelete