EIGRP Route summarization & Stub Sim on GNS3

EIGRP Stub CCNP Route Sim

By increasing the first distant office, PNG manufactures has extended their business. They configured the remote office router (R3) from which they can reach all corporate subnets. In order to raise network stableness and lower the memory usage and broadband utilization to R3, RB manufactures makes use of route summarization together with the EIGRP Stub Routing feature. Another network engineer is responsible for the implementing of this solution. However, in the process of configuring EIGRP stub routing connectivity with the remote network devices off of R3 has been missing.

Presently PNG has configured EIGRP on all routers in the network R2, R3, and R4. Your duty is to find and solve the connectivity failure problem with the remote office router R3. You should then configure route summarization only to the distant office router R3 to complete the task after the problem has been solved.
The success of pings from R4 to the R3 LAN interface proves that the fault has been corrected and the R3 IP routing table only contains two subnets.
GNS3 Configuration:
Create the above lab with following configurations in GNS3 and then practice this SIm with Real Exam configuration for your Route Exam.

R3 Configuration: R3(config)# interface Loopback1 R3(config-if)#ip address R3(config-if)#interface Serial1/0 R3(config-if)#ip address R3(config-if)# No shut
R3(config)#router eigrp 123 R3(config-rtr)#network
R3(config-rtr)#no auto-summary
R3(config-rtr)#eigrp stub receive-only
R4 Configuration:  R4(config)# interface Serial1/0 R4(config-if)#ip address
R4(config-if)# No shut
R4(config-if)#interface FastEthernet2/0
R4(config-if)#ip address
R4(config-if)# No shut
R4(config -rtr)#router eigrp 123
R4(config -rtr)#network
R4(config -rtr)#network
R4(config -rtr)#no auto-summary
R2 Configuration:
R2(config)#interface Loopback2 
R2(config-if)#ip address 
R2(config-if)# interface Loopback3 
R2(config-if)#ip address 
R2(config-if)#interface Loopback5 
R2(config-if)#ip address 
R2(config-if)#interface Loopback6 
R2(config-if)#ip address 
R2(config-if)#interface Loopback7 
R2(config-if)#ip address 
R2(config-if)#interface Loopback8 
R2(config-if)#ip address 
R2(config-if)#interface FastEthernet1/0 
R2(config-if)#ip address 
R2(config-if)# No shut R2(config-if)# end 
R2(config)# router eigrp 123 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#network 
R2(config -rtr)#no auto-summary

Real exam Configuration:
R4 & R3 are not communicating because of 
eigrp stub receive-only command in EIGRP Process 123. Due to this command router R3 is not sharing any of its routes with any other router in that EIGRP 123.
To make the communication possible we need to replace this with eigrp stub command. R3#configure terminal
R3(config)#router eigrp 123
R3(config-router)#no eigrp stub receive-only
R3(config-router)#eigrp stubR3(config-router)#end

You need to configure route summarization on R4 so that R3 has only 2 subnets of network. Use the show ip route command on R3 to view its routing table

For R3 only have 2 subnets we need Summarization at the R4's serial 1/0 interface which is connected with R3.
To fulfill this requirement we configure R4 as follow, R4>enable
R4#configure terminal
R4(config)#interface s1/0
R4(config-if)#ip summary-address eigrp 123


Now show ip route command to verify the effect, the output is shown below:

In your real exam IPs might be different so you need configure R4 according to requirements.

CCNP Route Labs


  1. I have one comment here about summary address it should be

    R4(config-if)#ip summary-address eigrp 123

    or I am wrong PLZ reply

    1. Yes, is more specific...

    2. I just took the test, and it does not accept is really silly. I spent a lot of time looking over my syntax and wondering why it wasn't working, remembered that I saw a /24 being used here and gave it shot...and the sim accepted it right away.

    3. I have just made this lab and it does support mask

    4. i try to also working can we use this ?

  2. hye bro.please help me.i already follow all ur configuration and when i want to check the ip route then it show me this error.can u help me.thanks

    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

  3. Typo in R4 solution config
    R4(config)#interface s0/0 -> R4(config)#interface s1/0

  4. Interesting that cisco would not accept a more specific route.