EIGRP single AS Configuration on GNS3

EIGRP single AS Configuration on GNS3

This is the simple tutorial for EIGRP configuration on GNS3. this topology consisit of six routers, you can use less routers, i am using six routers because in coming post i will show the EIGRP summarization, different AS configuration and MPLS configuration with this topology.

Create the topology as shown above in gns3, and configure all routers as follow.



R1 configuration:

R1#config t
R1(config)#int s1/0 
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#no shu
R1(config-if)#ex
R1(config)#int loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0 
R1(config-if)#int loopback 2
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#int loopback 3
R1(config-if)#ip address 192.168.3.1 255.255.255.0
R1(config-if)#int loopback 4
R1(config-if)#ip address 192.168.4.1 255.255.255.0
R1(config-if)#int loopback 5
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#int loopback 6
R1(config-if)#ip address 192.168.6.1 255.255.255.0
R1(config-if)#int loopback 7
R1(config-if)#ip address 192.168.7.1 255.255.255.0 
R1 EIGRP configuration commands:
R1(config)#router eigrp 100 
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 192.168.1.0 0.0.7.255
R1(config-router)#no auto-summary

I advertised all loopbacks from 192.168.1.0 to 192.168.7.0 by using command "network 192.168.1.0 0.0.7.255". Valid card mask 0.0.7.255 representing subnets from 0-7.



R2 configuration:
R2(config)#interface s1/0
R2(config-if)#ip address 1.1.1.2 255.255.255.0
R2(config-if)#no shu
R2(config-if)#int s1/1
R2(config-if)#ip address 2.2.2.1 255.255.255.0R2(config-if)#no shutdown
R2 EIGRP configuration commands:
R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 1.1.1.0 0.0.0.255
R2(config-router)#network 2.2.2.0 0.0.0.255

R3 configuration:
R3(config)#int s1/0
R3(config-if)#ip address 2.2.2.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#int s1/1
R3(config-if)#ip address 3.3.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#int s1/2
R3(config-if)#ip address 4.4.4.1 255.255.255.0
R3(config-if)#no shutdown
R3 EIGRP configuration commands:
R3(config)#router eigrp 100
R3(config-router)#no auto-summary
R3(config-router)#network 2.2.2.0 0.0.0.255
R3(config-router)#network 3.3.3.0 0.0.0.255
R3(config-router)#network 4.4.4.0 0.0.0.255

R4 configuration:
R4(config)#int s1/0
R4(config-if)#ip address 3.3.3.2 255.255.255.0
R4(config-if)#no shu
R4(config-if)#int s1/1
R4(config-if)#ip address 6.6.6.1 255.255.255.0
R4(config-if)#no shu
R4 EIGRP configuration commands:
R4(config)#router eigrp 100
R4(config-router)#network 3.3.3.0 0.0.0.255
R4(config-router)#network 6.6.6.0 0.0.0.255
R4(config-router)#no auto-summary


R5 configuration:
R5(config)#int s1/0
R5(config-if)#ip address 4.4.4.2 255.255.255.0
R5(config-if)#no shu
R5(config)#int gigabitEthernet 2/0
R5(config-if)#ip address 5.5.5.1 255.255.255.0
R5(config-if)#no shu
R5 EIGRP configuration commands:
R5(config)#router eigrp 100
R5(config-router)#network 4.4.4.0 0.0.0.255
R5(config-router)#network 5.5.5.0 0.0.0.255
R5(config-router)#no auto-summary

R6 configuration:
R6(config)#int g2/0
R6(config-if)#ip address 5.5.5.2 255.255.255.0
R6(config-if)#int g2/0
R6(config-if)#ip address 6.6.6.2 255.255.255.0
R6(config-if)#no shu
R6(config)#int loopback 1
R6(config-if)#ip address 200.1.0.1 255.255.255.0
R6(config-if)#int loopback 2
R6(config-if)#ip address 200.1.1.1 255.255.255.0
R6(config-if)#int loopback 3
R6(config-if)#ip address 200.1.2.1 255.255.255.0
R6(config-if)#int loopback 4
R6(config-if)#ip address 200.1.3.1 255.255.255.0
R6 EIGRP configuration commands:
R6(config)#router eigrp 100
R6(config-router)#network 200.1.0.0 0.0.3.255
R6(config-router)#network 5.5.5.0 0.0.0.255
R6(config-router)#network 6.6.6.0 0.0.0.255
R6(config-router)#no auto-summary

EIGRP Verification Commands:

"Show ip route" will show all networks on all routers.


 End to end ping should be successful.
 

Redistribute static route into EIGRP

9 comments:

  1. How did you configured :
    R6(config)#int g2/0
    R6(config-if)#ip address 5.5.5.2 255.255.255.0
    R6(config-if)#int g2/0
    What routers did you use and what images for this lab?
    Thank you

    ReplyDelete
    Replies
    1. hi serigne,
      this gigabit interface that i manually added in R6 you can use any other interface like FE, serial etc..

      Delete
  2. Thank you for your quick answer viki. Could you by any chance post the .net files of your labs, that would be very helpful!

    ReplyDelete
  3. working fine thank you..

    ReplyDelete
  4. hi viki.it's very good and easy ti learn of route summarization.

    ReplyDelete
  5. Thanks for a simple walk-through, although the one int g2/0 should be s1/0 on R6 but easy enough to find out by the illustration. Thanks for the help

    ReplyDelete
  6. plz write loopback eigrp configuration commands

    ReplyDelete
  7. can iu tell me why you use lookback on router 1 and router 6 i cant understand

    ReplyDelete
    Replies
    1. A loopback interface is a logical, virtual interface in a Cisco Router. A loopback interface is not a physical interface like Fast Ethernet interface or Gigabit Ethernet interface.
      A loopback interface has many uses.
      Loopback interface’s IP Address determines a router’s OSPF Router ID.A loopback interface is always up and allows Border Gateway Protocol (BGP) neighborship between two routers to stay up even if one of the outbound physical interface connected between the routers is down.
      Loopback interfaces are used as the termination points for Remote Source-Route Bridging (RSRB), and Data-Link Switching Plus (DLSW+). Loopback interfaces interfaces are always up and running and always available, even if other physical interfaces in the router are down.

      Delete

UA-23728446-1