LACP with STP Sim | Switch practice Lab

Link Aggregation Control Protocol Configuration:

Suppose you have just added a new switch (SwitchB) to the existing network as shown in the topology.


RouterA is currently configured correctly for providing the routing function for devices on SwitchA and SwitchB. You need to be modified SwitchA to support the addition of SwitchB. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.
Configuration Requirements for SwitchA
  • The VTP and STP configuration modes on SwitchA is correct and should not be modified. 
  • You need to configure SwitchA as root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB
You need to configure the VLANs according to following information:
VLAN#
VLAN NAME
VLAN Ports
21
HR
Fa1/9 and fa1/10
22
Finance
Fa1/5 and fa1/6
23
Marketing
Fa1/15 and fa1/14

– Access ports that assigned to VLANs should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA. And no routing is required on this Switch
–SVI vlan 1 is to be configured with IP address 192.168.1.11/24.
Inter-switch Connectivity Configuration Requirements:
- For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.

Answer and Explanation:
Some useful commands that may help you to find out the necessary information on SwitchA are as following: (Cisco basic router Commands)
show vtp status (you can get the information about VTP status on SwitchA i.e. SwitchA is in transparent mode)
show spanning-tree (rapid-pvst mode on SwitchA)
show vlan (check the native vlan and the existence of vlan100)
show etherchannel 1 port-channel and show ip int brief (check if Port-channel 1 has been created and make sure it is up)
show run (for complete configuration of Switch)


Configure the SwitchA as root switch for vlans 11, 12, 13, 21, 22 and 23 and need to have the same configuration as the SwitchB for successful configuration.
SwitchA>enable
SwitchA #configure terminal
SwitchA (config)#spanning-tree vlan 11,12,13,21,22,23 root primary
SwitchA (config)#vlan 21
SwitchA (config-vlan)#name HR
SwitchA (config-vlan)#exit
SwitchA (config)#vlan 22
SwitchA (config-vlan)#name Finance
SwitchA (config-vlan)#exit
SwitchA (config)#vlan 23
SwitchA (config-vlan)#name Marketing
SwitchA (config-vlan)#exit
SwitchA (config)#interface range Fa1/3 – 4
SwitchA (config-if-range)#switchport mode trunk
SwitchA (config-if-range)#switchport trunk native vlan 100
SwitchA (config-if-range)#switchport trunk allowed vlan 1,21,23
SwitchA (config-if-range)#channel-group 1 mode active
SwitchA (config-if-range)#channel-protocol lacp
SwitchA (config-if-range)#no shutdown
SwitchA (config-if-range)#end
——————————————————————————————–
Configuration VLANs according to given table:
SWITCHB#configure terminal
SWITCHB(config)#vlan 21
SWITCHB(config-vlan)#name HR
SWITCHB(config-vlan)#exit
SWITCHB(config)#vlan 22
SWITCHB(config-vlan)#name Finance
SWITCHB(config-vlan)#exit
SWITCHB(config)#vlan 23
SWITCHB(config-vlan)#name Marketing
SWITCHB(config-vlan)#exit
SWITCHB(config)#vlan 100
SWITCHB(config-vlan)#name TrunkNativeVlan
SWITCHB(config-vlan)#exit
SWITCHB(config)#interface range Fa1/9 – 10
SWITCHB(config-if-range)#switchport mode access
SWITCHB(config-if-range)#switchport access vlan 21
SWITCHB(config-if-range)#spanning-tree portfast (
Access ports that assigned to VLANs should transition immediately to forwarding state upon detecting the connection of a device.)
SWITCHB(config-if-range)#no shutdown
SWITCHB(config-if-range)#exit
SWITCHB(config)#interface range Fa1/5 – 6
SWITCHB(config-if-range)#switchport mode access
SWITCHB(config-if-range)#switchport access vlan 22
SWITCHB(config-if-range)#spanning-tree portfast
SWITCHB(config-if-range)#no shutdown
SWITCHB(config-if-range)#exit
SWITCHB(config)#interface range Fa1/14 – 15
SWITCHB(config-if-range)#switchport mode access
SWITCHB(config-if-range)#switchport access vlan 23
SWITCHB(config-if-range)#spanning-tree portfast
SWITCHB(config-if-range)#no shutdown
SWITCHB(config-if-range)#exit





SwitchB VTP mode needs to be the same as SwitchA:
SWITCHB(config)#vtp mode transparent
SWITCHB(config)#spanning-tree mode rapid-pvst
Configure VLAN-1 with IP address 192.168.1.1:
SWITCHB(config)#interface vlan 1
SWITCHB(config-if)#ip address 192.168.1.11 255.255.255.0
SWITCHB(config-if)#no shutdown
SWITCHB(config-if)#exit

Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link:

SWITCHB(config)#interface range Fa1/3 – 4
SWITCHB(config-if-range)#switchport trunk encapsulation dot1q
SWITCHB(config-if-range)#switchport mode trunk
SWITCHB(config-if-range)#switchport trunk native vlan 100
SWITCHB(config-if-range)#switchport trunk allowed vlan 1,21-23

Maximum use of bandwidth for all vlans with SwitchA controlling activation:
SWITCHB(config-if-range)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SWITCHB(config-if-range)#channel-protocol lacp
SWITCHB(config-if-range)#no shutdown
SWITCHB(config-if-range)#end

11 comments:

  1. hi,

    is it necessary to configure fa 0/3 & 0/4 with the native or allowed vlan commands as once they are grouped into the port-channel they use those settings right?

    ReplyDelete
  2. Hello everybody
    Is that enough to enable do1q on switch b only? do we need to do that on switch A as well?
    I believe that native vlan must match on both sides right ??
    Thanks

    ReplyDelete
    Replies
    1. I go thought with real lab in exam, switchB is 3500 series and other is 2900 series...For SwitchB we have to set the 802.1q trunking protocol before converting it into a trunk because it is a 3500series-switch which supports both ISL and 802.1Q, so we have to explicitly configfure which trunking protocol to be used. while the SwichA is a lower series switch, which does not support ISL trunking protocol (802.1Q is the only supported trunking protocol) so we can apply “switchport mode trunk” directly.

      Delete
  3. what about the command #switchport trunk allowed 1,21-23 on port-channel 1

    ReplyDelete
  4. encapsulation dot1q
    you can try it on Sw2 but Sw2 is a newer model , enabled by default. On sw1 you have to enable dot1q. You have to prune vlan, allowed vlan is pruned manually. And yes native vlan must match.
    Very good site thank you

    ReplyDelete
  5. SwitchA (config)#spanning-tree vlan 1,11,13,21,22,23 root primary

    You fogot vlan 12 ?

    ReplyDelete
    Replies
    1. Yes, You was right and it is updated now...Thank you..!

      Delete
  6. I think it is necessary to include the native VLAN within the VLAN allowed on the trunk

    switchport trunk allowed vlan 1,21-23,100

    ReplyDelete
  7. can we do this lab in gns3 and if yes how

    ReplyDelete
  8. This config on both switches is missing:

    interface Port-channel 1
    switchport trunk native vlan 99
    switchport mode trunk

    ReplyDelete
  9. How can I check if applaing all these config the lab working good? wich commands can I use tu check this? because I can´t send a ping from the server to the router

    ReplyDelete

UA-23728446-1