This is a simple tuttorial for configuring RIP on GNS3, i have create a small lab of three routers and two ethernet switches on GNS3 as shown in network diagram.
RIP routing protocol have simple configuration, you need a just network command to advertised the connected networks.
Configuration for R1:
R1(config-if)#ip add 100.1.1.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int s1/1
R1(config-if)#ip address 20.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ex
RIP Configuration Commands for R1:
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 20.1.1.0
R1(config-router)#network 100.1.1.0
Configuration for R2:
Show ip route command should display all RIP networks and end to end ping should be successful.
RIP routing protocol have simple configuration, you need a just network command to advertised the connected networks.
Configuration for R1:
R1#conf t
R1(config)#int s1/0R1(config-if)#ip add 100.1.1.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int s1/1
R1(config-if)#ip address 20.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ex
RIP Configuration Commands for R1:
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 20.1.1.0
R1(config-router)#network 100.1.1.0
Configuration for R2:
R2#config t
R2(config)#int f1/0
R2(config-if)#ip address 172.16.2.1 255.255.0.0
R2(config-if)#no shu
R2(config-if)#int s2/0
R2(config-if)#ip address 100.1.1.1 255.255.255.0
R2(config-if)#no shut
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.16.0.0
R2(config-router)#network 100.1.1.0
Configuration for R2:
R3(config)#int s2/0
R2(config)#int f1/0
R2(config-if)#ip address 172.16.2.1 255.255.0.0
R2(config-if)#no shu
R2(config-if)#int s2/0
R2(config-if)#ip address 100.1.1.1 255.255.255.0
R2(config-if)#no shut
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.16.0.0
R2(config-router)#network 100.1.1.0
Configuration for R2:
R3(config)#int s2/0
R3(config-if)#ip add 20.1.1.2 255.255.255.0
R3(config-if)#int f1/0
R3(config-if)#ip add 10.2.2.1 255.255.255.0
R3(config-if)#ex
R3(config)#router rip
R3(config-router)#ver 2
R3(config-router)#network 10.2.2.0
R3(config-router)#network 20.1.1.0
RIP Verification Commands:
I like your lab examples, but it would be nice to see a list of the router models you used and ISO versions (an abbreviated/content excluded sh ver from each router?).
ReplyDeleteI think the router models does not matter.
DeleteI agree. And please tell me also the switch config.
ReplyDeletePlease explain in details how to configure routers with interfaces and how to add pcs to the topology on gns3.
ReplyDeletegreat!..
ReplyDeletei like this!..great.
ReplyDeleteit is help full for me
ReplyDeleteI agree, it is really help full
ReplyDeleteBy using 2555.255.255.0 as a mask (S1/0 and S1/1 on R1 to connect to R2 and R3) arent we wasting IP addresses? 100.1.1.0 and 20.1.1.0 only connects two devices to R1 (R2 and R3)...Wouldnt it be more reliable if we've used a /30 mask?
ReplyDeletethank you bro
ReplyDeletethank you
ReplyDeleteObrigado!
ReplyDeletegooooooooooood
ReplyDeletegooooooooooood
ReplyDelete