OSPF network type point-to-multipoint is the RFC standard. the some feature of OSPF P2M are:
- Need Same subnet
- no need to configure static neighbours
- No DR/BDR
- Less PVCs required
I use a simple frame-relay topology for configuring OSPF point-to-multipoint on gns3. I use the c7200 IOS for this lab. Configure the topology as below:
GNS3 Frame-Relay switch Configuration:
Add the mapping as shown in figure for given topology.
R1 Configuration:
R1(config)# interface Serial1/0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# encapsulation frame-relay
R1(config-if)# ip ospf network point-to-multipoint
R1(config-if)# ip ospf 1 area 0
R1(config)# frame-relay map ip 10.1.1.2 200 broadcast
R1(config)# frame-relay map ip 10.1.1.3 300 broadcast
R1(config)# router ospf 1
R1(config-router)# router-id 1.1.1.1
R2 Configuration:
R2(config)# interface Serial1/0
R2(config-if)# ip address 10.1.1.2 255.255.255.0
R2(config-if)# encapsulation frame-relay
R2(config-if)# ip ospf network point-to-multipoint
R2(config-if)# ip ospf 1 area 0
R2(config)# exit
R2(config)# frame-relay map ip 10.1.1.1 100 broadcast
R2(config-if)# interface Loopback1
R2(config-if)# ip address 200.1.1.1 255.255.255.0
R2(config-if)# ip ospf 1 area 0
R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R3 Configuration:
R3(config)# interface Serial1/0
R3(config-if)# ip address 10.1.1.3 255.255.255.0
R3(config-if)# encapsulation frame-relay
R3(config-if)# ip ospf network point-to-multipoint
R3(config-if)# ip ospf 1 area 0
R3(config)# exit
R3(config)# frame-relay map ip 10.1.1.1 100 broadcast
R3(config)# router ospf 1Verifications:
"Show ip route" on all routers you should have all 3 OSPF routes.
Show Ip ospf neig: No DR/BDR in output
On all router sh ip ospf 1 interface s1/0 network type is P2M.
Good info !! Purely technical and logical.
ReplyDeletePoint to point wifi
For P2P OSPF just 2 routers, can we have different subnets and then have OSPF for routing? Will that work. If it has to be same SUBNET, it can form DIRECT CONNECTION and why exactly do we need any routing protocol there.
ReplyDeleteI am not sure I understand the question here. In order for OSPF adjacency to form they have to be on a common subnet. It is one of the few requirement for OSPF neighbors to form.
DeleteWhy routing protocol there? Because imagine if you had another router connected to R1 and it knows about a bunch of networks, how would R2 and R3 know about them? Well, if we had a routing protocol such as OSPF, R1 would then advertise those networks to R2 and R3.
I think you should look at a couple of my OSPF tutorials and it will make more sense.
http://ithitman.blogspot.com/2011/08/configuring-basic-ospf.html
http://ithitman.blogspot.com/2011/08/configuring-advanced-ospf_02.html
And when you are ready to go beyond you can check out the rest of my OSPF blogtorials.
http://ithitman.blogspot.com/search/label/OSPF