Frame-Relay Hub and spoke Configuration:
In OSPF non-broadcast mode has following features:
· All Router Must be on Same Subnet
· Statically configure the Neighbors
· Act Like a LAN Environment
· DR/BDR are selected, since there is not broadcast therefore you select DR and DR-other by priority command.
GNS3 Frame-Relay switch Configuration:
Add the mapping as shown in figure for given topology.
R1 Configuration:
interface Serial1/0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
ip ospf priority 255
ip ospf 1 area 0
serial restart-delay 0
frame-relay map ip 10.1.1.2 200 broadcast
frame-relay map ip 10.1.1.3 300 broadcast
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
neighbor 10.1.1.2 priority 0
neighbor 10.1.1.3 priority 0
ip ospf priority 255
R2 Configuration:
interface Loopback1
ip address 200.1.1.1 255.255.255.0
ip ospf priority 0
ip ospf 1 area 0
interface Serial1/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
ip ospf 1 area 0
frame-relay map ip 10.1.1.1 100 broadcast
frame-relay map ip 10.1.1.3 100 broadcast
router ospf 1
router-id 2.2.2.2
R3 Configuration:
interface Serial1/0
ip address 10.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
ip ospf 1 area 0
serial restart-delay 0
frame-relay map ip 10.1.1.1 100 broadcast
frame-relay map ip 10.1.1.2 100 broadcast
router ospf 1
router-id 3.3.3.3
Verification commands:
Show frame-rel ay map
Show ip route
Show ip ospf 1 neighbour
Show ip ospf 1 process
- Ping all other router should be successful.
- Use the traceroute command to verify that R1 is hub and other are spoke.
R3#trac 10.1.1.2
When I try to configure the frame replay port mappings as you listed above I am seeing an error stating "Mapping already defined"
ReplyDeleteCan't seem to figure this out. Im running GNS3 VirtualBox Edition
i think u just need to enter the left mapping colum in source and right in destination... e.g. from above figure u add
ReplyDeletesource
port 1
DLCI 200
Destination
port 2
DLCI 100
and so on
Nice post..I am really impressed and you do an appreciative work..Thanks for sharing.
ReplyDeletesame problem with me
ReplyDeletegive ip ospf priority 255 command under Serial x/x interface on R1 router problem solved.......
ReplyDelete